Status

P3
enhancement
RESOLVED DUPLICATE of bug 1399886
2 years ago
2 months ago

People

(Reporter: ntim, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Comment hidden (empty)
(Reporter)

Comment 1

2 years ago
Created attachment 8787395 [details] [diff] [review]
Define SVG fills with CSS
Attachment #8787395 - Flags: feedback?(bgrinstead)
(Reporter)

Comment 2

2 years ago
Created attachment 8787428 [details] [diff] [review]
Define SVG fills with CSS
Attachment #8787428 - Flags: feedback?(bgrinstead)
(Reporter)

Updated

2 years ago
Attachment #8787395 - Attachment is obsolete: true
Attachment #8787395 - Flags: feedback?(bgrinstead)
(Reporter)

Comment 3

2 years ago
Issues I've found:
- icons with hardcoded filters will have the wrong colour
- firebug theme is completely broken

I'll leave the feedback flag for code feedback.
Severity: normal → enhancement
Priority: -- → P3
Comment on attachment 8787428 [details] [diff] [review]
Define SVG fills with CSS

Review of attachment 8787428 [details] [diff] [review]:
-----------------------------------------------------------------

Interesting trick.  What does this buy us over the current filter approach though?

::: devtools/client/themes/common.css
@@ +544,5 @@
> +#requests-menu-perf-notice-button .button-icon,
> +#canvas-debugging-empty-notice-button .button-icon,
> +#toggle-breakpoints[checked] > image,
> +.event-tooltip-debugger-icon {
> +  filter: url("images/filters.svg#fill");

Shouldn't this still use the invert filter as before - and only use the #fill filter for checked icon state where we know the color we want to get to?

@@ +545,5 @@
> +#canvas-debugging-empty-notice-button .button-icon,
> +#toggle-breakpoints[checked] > image,
> +.event-tooltip-debugger-icon {
> +  filter: url("images/filters.svg#fill");
> +  fill: currentColor;

I don't think the fill should be related to the text color of these elements, might be why this isn't working in the firebug theme
Attachment #8787428 - Flags: feedback?(bgrinstead)
(Reporter)

Comment 5

2 years ago
Not going to work on this anytime soon
Assignee: ntim.bugs → nobody
Status: ASSIGNED → NEW
(Reporter)

Updated

10 months ago
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1399886

Updated

2 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.