[FIX]Incremental reflow of fixed-pos elements uses wrong width/height

VERIFIED FIXED in mozilla1.0

Status

()

P1
normal
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: bzbarsky, Assigned: bzbarsky)

Tracking

Trunk
mozilla1.0
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

BUILD: 2002-03-10-07 (as well as all Mozilla builds as far back as I can
       remember).

STEPS TO REPRODUCE:
1)  Load attached testcase
2)  Make sure a vertical scrollbar is present; shorten window as necessary until
    this is true.
3)  Mouse over the "This text should not go under the scrollbar when hovered"
    text.

EXPECTED RESULTS:  Text stays up against the right edge of the visible viewport
                   area when hovered.

ACTUAL RESULTS:  Text moves under the vertical scrollbar and is no longer all
                 visible
Created attachment 73492 [details]
testcase for this bug
The patch just copies the rigmarole we go through elsewhere in this file before
calling ReflowFixedFrame().
Priority: -- → P1
Target Milestone: --- → mozilla1.0
Comment on attachment 73493 [details] [diff] [review]
Patch to fix

r=dbaron, although you could just cast away const on the existing reflow state,
change the width and height, and then change them back when you're done.  (We
do that in other places, I think.)
Attachment #73493 - Flags: review+

Updated

17 years ago
Attachment #73493 - Flags: superreview+

Comment 6

17 years ago
Comment on attachment 73493 [details] [diff] [review]
Patch to fix

sr=attinasi (and I prefer the copied RS to poking values into the original one,
just on stylistic grounds you understand.  Performance is probably not a big
issue here anyway).

Comment 7

17 years ago
*** Bug 60499 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
Changing QA contact
QA Contact: petersen → amar
checked into trunk
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
*** Bug 116792 has been marked as a duplicate of this bug. ***

Comment 12

17 years ago
Great! this bug has been one of the more annoying ones to me :)

verified fixed
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.