tracking protection (strict list) blocks bing maps v8

RESOLVED WONTFIX

Status

()

Firefox
Tracking Protection
--
minor
RESOLVED WONTFIX
2 years ago
5 months ago

People

(Reporter: steffen.mangold, Unassigned)

Tracking

(Blocks: 1 bug, {privacy})

48 Branch
privacy
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: tp-content tp-product)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160823121617

Steps to reproduce:

Trying to load bing maps V8 web control.
"https://www.bing.com/api/maps/mapcontrol?branch=experimental?callback=define&callback=__async_req_1__"


Actual results:

Firefox Tracking-Safety is blocking bing maps url.


Expected results:

Bing maps url should not be blocked because not tracking related.
(Reporter)

Updated

2 years ago
Severity: normal → minor
Keywords: privacy

Comment 1

2 years ago
I tried to test this on Windows 10 x64 with FF 48 and Nightly 51.0a1 and I can't open the link that you provided. I tried with other browsers and the result is the same, I have a lot of text when I open the link. 
Please provide some steps to try to reproduce this.
Flags: needinfo?(steffen.mangold)
(Reporter)

Comment 2

2 years ago
(In reply to ovidiu boca[:Ovidiu] from comment #1)
> I tried to test this on Windows 10 x64 with FF 48 and Nightly 51.0a1 and I
> can't open the link that you provided. I tried with other browsers and the
> result is the same, I have a lot of text when I open the link. 
> Please provide some steps to try to reproduce this.

Yes the link is only the SDK link for the bing map JS library.
You can reproduce it by open the demo portal: http://www.bing.com/api/maps/sdk/mapcontrol/isdk#loadMapAsync+JS

Comment 3

2 years ago
Thanks Steffen, here is what I did:

Open FF 48.0.2 release and then go to http://www.bing.com/api/maps/sdk/mapcontrol/isdk#loadMapAsync+JS

Everything works fine, I can see my location. 
Can you please try in safe mode, https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Also if the steps that I followed are not the correct ones, please tell me.
(Reporter)

Comment 4

2 years ago
Sorry wrong URL. Please test with: https://jsfiddle.net/ty64sLvz/
Please make sure you have activate "Protect for activity tracking" under "Privacy" options.
(Reporter)

Comment 5

2 years ago
(In reply to ovidiu boca[:Ovidiu] from comment #3)
> Thanks Steffen, here is what I did:
> 
> Open FF 48.0.2 release and then go to
> http://www.bing.com/api/maps/sdk/mapcontrol/isdk#loadMapAsync+JS
> 
> Everything works fine, I can see my location. 
> Can you please try in safe mode,
> https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-
> mode
> 
> Also if the steps that I followed are not the correct ones, please tell me.

It only happens if the source website is a different domain as www.bing.com.
Thats why my first example has no problem (same domain) and the second one you get an error.

Comment 6

2 years ago
Can you please attached a printscreen or a video recording this issue? 
I tested with the link provided in comment 4 but I can't see any error. 

Please try in safe mode, https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
Do you have add-ons installed?
(Reporter)

Comment 7

2 years ago
(In reply to ovidiu boca[:Ovidiu] from comment #6)
> Can you please attached a printscreen or a video recording this issue? 
> I tested with the link provided in comment 4 but I can't see any error. 
> 
> Please try in safe mode,
> https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-
> mode
> Do you have add-ons installed?

No addons. But I do some more test and its only happens on the Mac version of FF. On windows the map is not blocked even in privacy mode.
(Reporter)

Comment 8

2 years ago
Error from console: "The resource on 'https://www.bing.com/api/maps/mapcontrol?branch=experimental?callback=define&callback=__async_req_1__' has been blocked, because the tracking protection is active"

Comment 9

2 years ago
I can't reproduce this issue on Mac OS X 10.10 with FF 48 or FF 51.0a1, tested with new profile.
Component: Untriaged → Tracking Protection
Flags: needinfo?(steffen.mangold)
bing.com is in the Content category of Disconnect's list: https://github.com/mozilla-services/shavar-prod-lists/blob/ce41e57e1c9e8cbf6bb2eb4b7645ca45e376c196/disconnect-blacklist.json#L7952
Blocks: 1101005
Summary: privacy mode blocks bing maps v8 → tracking protection (strict list) blocks bing maps v8
Whiteboard: tp-content tp-product
Given that a user needs to enable the strict list and there is a warning about breakage, we won't spend time trying to fix this issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.