Closed Bug 1300055 Opened 3 years ago Closed 3 years ago

When you share the screen, under the Permissions camera appears.

Categories

(Firefox :: Device Permissions, defect, P1)

51 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1299783
Tracking Status
firefox51 --- verified
firefox52 --- verified

People

(Reporter: Ovidiu, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [fxprivacy])

Attachments

(1 file)

Affected versions]:

FF Nightly 51.0a1


[Affected platforms]:

Mac OS 10.10, Windows 10 x64, Ubuntu 15.04

[Steps to reproduce]:

1. Go to https://people.mozilla.org/~fqueze2/webrtc/ and share your screen.
2. In a new Tab repeat the first step.
 


[Expected result]:

The screen that you choose to share appears. The "i" from the address bar starts to alternate with a red monitor icon. Under the Permissions you see only "Share the Screen" icon.

[Actual result]:

Under the Permissions you see  "Share the Screen" icon and "Use the Camera" icon.
Please see the attachement. 

Note:

The same think happens if I choose to share my window.
Whiteboard: [fxprivacy] [triage]
Whiteboard: [fxprivacy] [triage] → [fxprivacy] [triage]
We should fix this sooner than later, but I suspect it'll turn out to have the same root cause as bug 1299783.
See Also: → 1299783
Assignee: nobody → florian
Status: NEW → ASSIGNED
Priority: -- → P1
Whiteboard: [fxprivacy] [triage] → [fxprivacy]
Both bug 1299783 and this are caused by bug 1177242.
Blocks: 1177242
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Keywords: regression
Resolution: --- → DUPLICATE
Duplicate of bug: 1299783
Assignee: florian → nobody
This needs QE's help to verify.
Flags: qe-verify?
Hi :Ovidiu,
Can you help to verify if this is fixed in nightly & 51 aurora?
Flags: needinfo?(ovidiu.boca)
Sure Gerry, 

I verified this on FF Nighlty 52.0a1 (2016-10-23) and on FF Dev. Edition 51.0a2 (2016-10-24) with Mac OS X 10.10 and I can confirm the fix. I can no longer reproduce this issue.
Flags: needinfo?(ovidiu.boca)
You need to log in before you can comment on or make changes to this bug.