Closed Bug 1300059 Opened 5 years ago Closed 5 years ago

TEST-UNEXPECTED-FAIL | mailnews/compose/test/unit/test_autoReply.js and many more

Categories

(Thunderbird :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 52.0

People

(Reporter: jorgk-bmo, Assigned: aleth)

References

Details

(Keywords: intermittent-failure)

First seen: Fri Sep 2, 2016, 0:18:50
https://treeherder.mozilla.org/#/jobs?repo=comm-central&revision=f3f22e07b8e8beb02592cd68c83267fe570e59e9

TEST-UNEXPECTED-FAIL | mailnews/compose/test/unit/test_autoReply.js | xpcshell return code: 0
TEST-UNEXPECTED-FAIL | mailnews/compose/test/unit/test_sendMessageLater2.js | xpcshell return code: 0
TEST-UNEXPECTED-FAIL | mailnews/compose/test/unit/test_sendMessageLater2.js | _async_driver - TypeError: ex.stack is undefined at ../../../resources/asyncTestUtils.js:178
TEST-UNEXPECTED-FAIL | mailnews/local/test/unit/test_pop3PasswordFailure2.js | xpcshell return code: 0
TEST-UNEXPECTED-FAIL | mailnews/local/test/unit/test_pop3PasswordFailure2.js | alert - [alert : 37] false == true
TEST-UNEXPECTED-FAIL | mailnews/local/test/unit/test_pop3PasswordFailure2.js | urlListener.OnStopRunningUrl - [urlListener.OnStopRunningUrl : 96] 2147500037 == 0
TEST-UNEXPECTED-FAIL | mailnews/local/test/unit/test_pop3PasswordFailure3.js | xpcshell return code: 0
TEST-UNEXPECTED-FAIL | mailnews/local/test/unit/test_pop3PasswordFailure3.js | alert - [alert : 39] false == true
TEST-UNEXPECTED-FAIL | mailnews/local/test/unit/test_pop3PasswordFailure3.js | urlListener.OnStopRunningUrl - [urlListener.OnStopRunningUrl : 98] 2147500037 == 0
TEST-UNEXPECTED-FAIL | mailnews/news/test/unit/test_nntpPasswordFailure.js | xpcshell return code: 0
TEST-UNEXPECTED-FAIL | mailnews/news/test/unit/test_nntpPasswordFailure.js | urlListener.OnStopRunningUrl - [urlListener.OnStopRunningUrl : 91] 0 == 1

Note the:
TypeError: ex.stack is undefined at ../../../resources/asyncTestUtils.js:178
Looks like the failures have to do with a login. Looking at the log we see:

17:26:37     INFO -  "CONSOLE_MESSAGE: (error) [JavaScript Error: "TypeError: can't convert null to object" {file: "resource://gre/components/nsLoginManagerPrompter.js" line: 688}]"
17:26:37     INFO -  Error console says [stackFrame nsPrompter: Delegation to password manager failed: [Exception... "[JavaScript Error: "can't convert null to object" {file: "resource://gre/components/nsLoginManagerPrompter.js" line: 688}]'[JavaScript Error: "can't convert null to object" {file: "resource://gre/components/nsLoginManagerPrompter.js" line: 688}]' when calling method: [nsIPromptFactory::getPrompt]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: resource://gre/components/nsPrompter.js :: Prompter.prototype.getPrompt :: line 42"  data: yes]]

Looks like it's caused by bug 1266836.
Summary: Massive Xpcshell failure on all platforms: TEST-UNEXPECTED-FAIL | mailnews/compose/test/unit/test_autoReply.js and many more → Multiple Xpcshell failure on all platforms: TEST-UNEXPECTED-FAIL | mailnews/compose/test/unit/test_autoReply.js and many more
Aleth, what do you think, are these "only" test failures or have we actually lost functionality that Dailies will not work in some respect?
Flags: needinfo?(aleth)
It's hard to say just from a quick glance. The login prompter idl has changed in minor ways, so it's possible something is now broken. Clearly, from the log, at least in the test "entering the password" fails to work.
Flags: needinfo?(aleth)
test_autoReply.js and test_sendMessageLater2.js fail because this if clause fails: https://hg.mozilla.org/mozilla-central/rev/6a563348b8be#l5.15
These tests doesn't really involve logins at all though, at least there's no mention of it in the test. Probably can be worked around in the test.

The other failures actually test login issues. There, the issue is probably in alertTestUtils.js.
Blocks: 1266836
Assignee: nobody → aleth
(In reply to aleth [:aleth] from comment #4)
> The other failures actually test login issues. There, the issue is probably
> in alertTestUtils.js.

Actually, it was simpler than that. Patch filed in the blocking bug.
(In reply to aleth [:aleth] from comment #4)
> test_autoReply.js and test_sendMessageLater2.js fail because this if clause
> fails: https://hg.mozilla.org/mozilla-central/rev/6a563348b8be#l5.15
> These tests doesn't really involve logins at all though, at least there's no
> mention of it in the test. Probably can be worked around in the test.

I filed a patch to take care of this in m-c, let's see if it is acceptable.
Summary: Multiple Xpcshell failure on all platforms: TEST-UNEXPECTED-FAIL | mailnews/compose/test/unit/test_autoReply.js and many more → TEST-UNEXPECTED-FAIL | mailnews/compose/test/unit/test_autoReply.js and many more
Depends on: 1301109
Fixed by bug 1301109 on mozilla52 with uplift to mozilla51, so Aurora (TB 51) Xpcshell test failures will eventually go away.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 52.0
You need to log in before you can comment on or make changes to this bug.