address bar autofill takes site under cursor not the one entered

RESOLVED DUPLICATE of bug 1292310

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 1292310
2 years ago
2 years ago

People

(Reporter: onorua, Unassigned)

Tracking

51 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20160901030202

Steps to reproduce:

I'm entering some site name until autofill is pointing to the correct site, and then hit <Enter>. 


Actual results:

In case mouse cursor outside firefox windows - it works as expected, but in case mouse cursor is somewhere above autofill dropdown, firefox goes to site under cursor


Expected results:

It should ignore cursor position when keyboard is used (I hit enter), and respect mouse position on the time of click only.

Updated

2 years ago
Status: UNCONFIRMED → NEW
Component: Untriaged → Location Bar
Ever confirmed: true

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1292310
You need to log in before you can comment on or make changes to this bug.