Update gradle (2.14.1) and android gradle plugin (2.1.3)

RESOLVED FIXED in Firefox 52

Status

defect
P1
normal
RESOLVED FIXED
3 years ago
2 days ago

People

(Reporter: sebastian, Assigned: Grisha)

Tracking

unspecified
mozilla52
All
Android

Firefox Tracking Flags

(firefox52 fixed)

Details

(Whiteboard: [MobileAS])

Attachments

(2 attachments)

The new version of Android Studio (2.2 Beta 3) is bugging more often to update Gradle and the Android gradle plugin.

* Gradle: 2.10 -> 2.14.1 (gradle-wrapper.properties)
* Plugin: 2.1.0 -> 2.1.3 (build.gradle)

Currently Android 2.2 Beta 3 is only available in the preview channel.
Android Studio keeps bugging me as well, so let's give this a go.
Some tests are failing locally.

testDSAGeneration is probably fine (don't have crypto... "things"... setup locally), but other failures are not fine.

Some "can't open SQL connection" errors in there.

"android.database.sqlite.SQLiteException: Cannot open SQLite connection, base error code: 14
	at org.robolectric.shadows.ShadowSQLiteConnection.rethrow(ShadowSQLiteConnection.java:56)
	at org.robolectric.shadows.ShadowSQLiteConnection.access$500(ShadowSQLiteConnection.java:33)
	at org.robolectric.shadows.ShadowSQLiteConnection$Connections.execute(ShadowSQLiteConnection.java:466)
	at org.robolectric.shadows.ShadowSQLiteConnection$Connections.open(ShadowSQLiteConnection.java:353)
	at org.robolectric.shadows.ShadowSQLiteConnection.nativeOpen(ShadowSQLiteConnection.java:61)
	at android.database.sqlite.SQLiteConnection.nativeOpen(SQLiteConnection.java)
"

More failures:

:app:testAutomationDebugUnitTest

org.mozilla.gecko.browserid.test.TestJSONWebTokenUtils > testDSAGeneration FAILED
    org.junit.ComparisonFailure at TestJSONWebTokenUtils.java:125

org.mozilla.gecko.db.BrowserProviderHistoryTest > testHistoryExpirationNormalOld FAILED
    java.lang.AssertionError at BrowserProviderHistoryTest.java:328

org.mozilla.gecko.db.BrowserProviderHistoryTest > testHistoryVisitAggregates FAILED
    java.lang.AssertionError at BrowserProviderHistoryTest.java:273

org.mozilla.gecko.icons.loader.TestLegacyLoader > testDatabaseIsQueriesForNormalRequestsWithNetworkSkipped FAILED
    android.database.sqlite.SQLiteException at TestLegacyLoader.java:42
        Caused by: com.almworks.sqlite4java.SQLiteException

org.mozilla.gecko.background.db.TestTabsProviderRemoteTabs > testGetClientsWithoutTabsByRecencyFromCursor FAILED
    android.database.sqlite.SQLiteException at TestTabsProviderRemoteTabs.java:65
        Caused by: com.almworks.sqlite4java.SQLiteException

651 tests completed, 5 failed, 2 skipped
:app:testAutomationDebugUnitTest FAILED
Assignee: nobody → gkruglov
Status: NEW → ASSIGNED
I'm seeing all of the same test failures locally without these changes. Strange.
This also needs any relevant releng.manifest changes.
For running all unit tests locally you'll have to follow those steps. However testDSAGeneration will still fail locally (bug 1275423).
https://mail.mozilla.org/pipermail/mobile-firefox-dev/2015-September/001499.html
Flags: needinfo?(s.kaspari)
Comment on attachment 8792149 [details]
Bug 1300094 - Update Gradle to 2.14.1 and Gradle Plugin to 2.1.3

https://reviewboard.mozilla.org/r/79360/#review79168

::: gradle/wrapper/gradle-wrapper.properties:7
(Diff revision 3)
>  distributionBase=GRADLE_USER_HOME
>  distributionPath=wrapper/dists
>  zipStoreBase=GRADLE_USER_HOME
>  zipStorePath=wrapper/dists
> -distributionUrl=https\://services.gradle.org/distributions/gradle-2.10-all.zip
> -distributionSha256Sum=496d60c331f8666f99b66d08ff67a880697a7e85a9d9b76ff08814cf97f61a4c
> +distributionUrl=https\://services.gradle.org/distributions/gradle-2.14.1-all.zip
> +distributionSha256Sum=65bbc0ef9c48be86fb06522fc927d59dcc7c04266f2bb8156be76971f7c3fc4a

When downloading this build then our servers (and I locally) get a distribution with a different checksum: 88a910cdf2e03ebbb5fe90f7ecf534fc9ac22e12112dc9a2fee810c598a76091
I uploaded new versions of gradle-dist.tar.xz and jcentral.tar.xz to tooltool so that you can update the releng manifests:

> [
> {
> "size": 51512016,
> "visibility": "public",
> "digest": "36f961f85b0be846cc9e72bfa0dd1f74e7da8ef785717ce4fd102fec977f21f8902c233b28a21c1ce3797eb2759c7a74c5f74e47bd8f13c1eec640f8d7bed4ac",
> "algorithm": "sha512",
> "filename": "gradle-dist.tar.xz"
> },
> {
> "size": 47315996,
> "visibility": "public",
> "digest": "66640e3f77a0f9c0ea52f66c53bee8db3c1a27ea4a11526d15706b9da6a0302cd2d5b088f9addca84f4a962022cba3b76829cb878c90cf9bebb3aab050b4aaa4",
> "algorithm": "sha512",
> "filename": "jcentral.tar.xz"
> }
> ]
Flags: needinfo?(s.kaspari)
Priority: P2 → P1
Whiteboard: [MobileAS]
Comment on attachment 8792149 [details]
Bug 1300094 - Update Gradle to 2.14.1 and Gradle Plugin to 2.1.3

https://reviewboard.mozilla.org/r/79360/#review79352
Attachment #8792149 - Flags: review?(s.kaspari) → review+
Comment on attachment 8792157 [details]
Bug 1300094 - Update robolectric to 3.1.2

https://reviewboard.mozilla.org/r/79370/#review79354
Attachment #8792157 - Flags: review?(s.kaspari) → review+
Pushed by gkruglov@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0ddc2c7f93d5
Update Gradle to 2.14.1 and Gradle Plugin to 2.1.3 r=sebastian
https://hg.mozilla.org/integration/autoland/rev/1d740c4cec92
Update robolectric to 3.1.2 r=sebastian
https://hg.mozilla.org/mozilla-central/rev/0ddc2c7f93d5
https://hg.mozilla.org/mozilla-central/rev/1d740c4cec92
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 52
After updating Android Studio to the current latest stable version (2.2), it's now prompting me to update Gradle plugin version to 2.2.0.
See Also: → 1305494
Iteration: --- → 1.5
Product: Firefox for Android → Firefox Build System
Target Milestone: Firefox 52 → mozilla52
You need to log in before you can comment on or make changes to this bug.