Screen Orientation angle is incorrect when orientation is locked

RESOLVED DUPLICATE of bug 1112531

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 1112531
a year ago
a year ago

People

(Reporter: cameron, Unassigned)

Tracking

48 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8787695 [details]
test_screen_orientation_angle.html

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/53.0.2785.89 Safari/537.36

Steps to reproduce:

1. Hold device in portrait-primary orientation.
2. Listen for the screen.orientation change event.
3. Trigger requestFullScreen.
4. Trigger screen.orientation.lock('landscape-primary')
5. Read the screen.orientation.angle value.

Tested on a Nexus 5X running Android 6.0.1 and Firefox 48.0.


Actual results:

The screen.orientation.angle value is 0. This would make sense if the orientation was still portrait-primary, but not for landscape-primary on this device.


Expected results:

The screen.orientation.angle value should be 90 for this device, as the orientation has changed to landscape-primary.

See Section 4.1 of the Screen Orientation API for expected behaviour of the angle value: https://www.w3.org/TR/screen-orientation/#reading-the-screen-orientation

Comment 1

a year ago
Thank you Cameron for the detailed steps you provided, I was able to reproduce it. However I'll make it a duplicate of bug 1112531.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1112531
You need to log in before you can comment on or make changes to this bug.