Closed Bug 1300169 Opened 5 years ago Closed 5 years ago

MediaRecorder video and audio are very out of sync

Categories

(Core :: Audio/Video: Recording, defect, P1)

51 Branch
Unspecified
All
defect

Tracking

()

RESOLVED DUPLICATE of bug 1300871

People

(Reporter: zach, Unassigned)

Details

(Keywords: regression, regressionwindow-wanted)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.116 Safari/537.36

Steps to reproduce:

Using the Firefox Nightly 51.0a1 (2016-09-02) with the example recorder at https://www.webrtc-experiment.com/msr/video-recorder.html I set the Time interval to 50000 and clicked "Start". I snapped the clap board several times saying the word "snap" each time. I also counted down from 10 holding up fingers (mod 5) to show what number I was saying. 


Actual results:

You can see that the audio lags behind the video by about 1 second. The sound of the clap board, the sync of the lips, and the sync with the fingers is all evidence of how far off it is. 

This problem did not exist on FF47.

FF48 introduced a different timestamp bug https://bugzilla.mozilla.org/show_bug.cgi?id=1294753 but the resolution of that bug has left this syncing problem in place. 


Expected results:

The audio and video should be in sync. The snap sound should happen at the moment the clap board closes, the fingers should reflect the number I am saying (mod 5), and my lips should sync with the words I am saying.
Here is an example recorded using Nightly 2016-09-02: 
https://drive.google.com/open?id=0B0Obs7dybjLVVU9wWkNzdDhfRjA

Here is an example recorded using Beta 49.0b6:
https://drive.google.com/open?id=0B0Obs7dybjLVRDctd0lLRDNqVTQ

The bug is in Nightly but NOT in Beta. The a/v sync in Beta seems ok.
This bug does NOT occur in Developers Edition 50.0a2 (2016-09-02). 
https://drive.google.com/open?id=0B0Obs7dybjLVTGdGOU5HOHZRUm8
Severity: normal → major
OS: Unspecified → Mac OS X
Component: Untriaged → WebRTC: Audio/Video
Product: Firefox → Core
Component: WebRTC: Audio/Video → Audio/Video: Recording
Rank: 15
Priority: -- → P1
Someone cloned this as a win10 bug, so I think it's all platforms.
OS: Mac OS X → All
(In reply to zach from comment #3)
> Someone cloned this as a win10 bug, so I think it's all platforms.

https://bugzilla.mozilla.org/show_bug.cgi?id=1300650
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1300871
You need to log in before you can comment on or make changes to this bug.