Closed Bug 1300291 Opened 3 years ago Closed 3 years ago

Fix background-color and icon color of all-tabs-menu

Categories

(DevTools :: Inspector, defect, P1)

defect

Tracking

(firefox51 verified, firefox52 verified)

VERIFIED FIXED
Firefox 52
Iteration:
52.1 - Oct 3
Tracking Status
firefox51 --- verified
firefox52 --- verified

People

(Reporter: magicp.jp, Assigned: Honza)

References

Details

(Keywords: good-first-bug, Whiteboard: [reserve-html])

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20160902030222

Steps to reproduce:

1. Start Nightly
2. Open DevTools > Inspector
3. Resize sidebar until displaying all-tabs-menu
4. Check background-color and icon color of all-tabs-menu



Actual results:

all-tabs-menu has disabled style even if it is enabled.


Expected results:

all-tabs-menu has correct style.
Regression range:
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=b18c8bcdc116eef8799880b7c50317bf54218474&tochange=6a5af5a4c2efd7df3bd8eb6f87ad6ef654854090
Blocks: 1281789
Has Regression Range: --- → yes
Has STR: --- → yes
Component: Untriaged → Developer Tools: Inspector
I can see all-tabs-menu on Windows and Linux. It is not displayed on Mac OS X.
Flags: qe-verify+
QA Contact: cristian.comorasu
Whiteboard: [devtools-html] [triage]
Priority: -- → P3
Whiteboard: [devtools-html] [triage] → [reserve-html]
Keywords: good-first-bug
Assignee: nobody → odvarko
Status: NEW → ASSIGNED
Iteration: --- → 52.1 - Oct 3
Priority: P3 → P1
Attached patch bug1300291.patchSplinter Review
- The background color of the all tabs menu fixed.
- The icon-color (little triangle) is kept. It's the same color as e.g. the 'Select iframe' command-button icon is using (and also the light theme is using).
- Little clean up, using --theme-tab-toolbar-background variable for the bk color
- Due to the clean up, bk color for Performance CallTree header is now also using the right (blueish) color.

Honza
Attachment #8793331 - Flags: review?(ntim.bugs)
Comment on attachment 8793331 [details] [diff] [review]
bug1300291.patch

Can you file another bug for the icon color?
Attachment #8793331 - Flags: review?(ntim.bugs) → review+
(In reply to Tim Nguyen :ntim (use needinfo?) from comment #4)
> Comment on attachment 8793331 [details] [diff] [review]
> bug1300291.patch
> 
> Can you file another bug for the icon color?
Done, bug 1305049

Thanks for the review Tim!

Honza
Keywords: checkin-needed
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/fx-team/rev/1e09dde7c7fa
Fix background-color and icon color of all-tabs-menu; r=ntim
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/1e09dde7c7fa
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 52
Hi :Honza, 
Do you think this is worth uplifting to 51 aurora?
Flags: needinfo?(odvarko)
I reproduced this bug using Fx 51.0a1, build ID:20160915030417, on Windows 10 x64.
I could not reproduce this bug using Fx 51.0a1, build ID:20160915030417, on Mac 10.10.5, the all-tabs-menu was not displayed.
I can confirm this issue is fixed, I verified using Fx 52.0a1 build ID:20160927030200, on Windows 10 x64, Ubuntu 14.04 LTS and Mac OS X 10.10.5, on this Fx version the all-tabs-menu is displayed.
Flags: qe-verify+
Comment on attachment 8793331 [details] [diff] [review]
bug1300291.patch

(In reply to Gerry Chang [:gchang] from comment #8)
> Hi :Honza, 
> Do you think this is worth uplifting to 51 aurora?
Good point, yes.


Approval Request Comment
[Feature/regressing bug #]: Bug 1281789
[User impact if declined]: Wrong background color of a button
[Describe test coverage new/current, TreeHerder]: n/a
[Risks and why]: Low risk, CSS change only

Honza
[String/UUID change made/needed]:
Flags: needinfo?(odvarko)
Attachment #8793331 - Flags: approval-mozilla-aurora?
Status: RESOLVED → VERIFIED
Comment on attachment 8793331 [details] [diff] [review]
bug1300291.patch

This patch polishes UI. Take it in 51 aurora.
Attachment #8793331 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
I can confirm this issue is also fixed on Fx 51.0a2, build ID: 20160930004005, I verified on Windows 10 x64 and Ubuntu 14.04 LTS.

However on Mac there is a resize issue, see bug 1306649 .
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.