java chat crashes the browser

RESOLVED WORKSFORME

Status

defect
P2
critical
RESOLVED WORKSFORME
17 years ago
9 years ago

People

(Reporter: sample3000us, Assigned: peterl-bugs)

Tracking

({crash})

Trunk
Future
PowerPC
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

21.74 KB, application/octet-stream
Details
(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:0.9.8) Gecko/20020216
BuildID:    20020216

when I go to this site, mozilla just dies...it winks out of existence!

Reproducible: Always
Steps to Reproduce:
1.Just go to that site
2.
3.

Most of the Java items on the java.sun.com site work...but not all of them. The
about: tells me this, BTW...Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:0.9.8)
Gecko/20020216

I'm running debian's woody (aka unstable) on a powermac g3/266 beige desktop

Comment 1

17 years ago
WFM 2002031008/Win2K
Keywords: crash
Couldn't reproduce crash on linux(deb/i386) cvs 2002-03-11 or 0.9.8 branch
nightly 2002020412, with or without java and/or flash installed. ->plugins
Assignee: asa → av
Status: UNCONFIRMED → NEW
Component: Browser-General → Plug-ins
Ever confirmed: true
QA Contact: doronr → shrir

Comment 3

17 years ago
wfm 2002030614 (0.9.9 branch)

java version "1.4.0"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.0-b92)
Java HotSpot(TM) Client VM (build 1.4.0-b92, mixed mode)

Comment 4

17 years ago
platform 'mac'.. os 'linux' ?  anyway...sending to oji...
Assignee: av → joe.chou
Component: Plug-ins → OJI
QA Contact: shrir → pmac

Comment 5

17 years ago
Sorry, I forgot that my system runs w2k. See comment 3.

Comment 6

17 years ago
reporter: what is your java plugin?

Comment 7

17 years ago
Got info about jre from reporter:

> I believe it's /usr/lib/j2re1.3.1/plugin/ppc/mozilla/javaplugin_oji.so
> It's the blackdown version...

Comment 8

17 years ago
I'd add some more links or references in which Mozilla would hang.

The story is generally that, that Mozilla does not hang the computer (so one
would have to use the Reset-button on PC-s) when Java is off. When Java in on
and certain stuff works there, like chat, then it is more likely to crash.

Browser info: Mozilla 0.9.9, JRE 1.3.1_01a (I guess this is the one, or just
1.3.1_01). I thought I'd separately install 1.3.1_01a, because this version was
alot more stable. OS: Windows Me with a good computer (that's objectionalble,
but what the heck) - Either it's Pentium II or Celeron (Don't know exactly,
because the processor data is contradictory) with some 600MHz, 128Mb RAM, a
sound card and so on.

Observations.
Mozilla usually hangs when music is playing in WinAmp. I haven't tried out in
RealPlayer, because I don't use RealPlayer that often (I'll report if anything
like this happens). So, when it hangs, the music in WinAmp just stops playing on
and I can't move the mouse cursor. And the crash is such that TalkBack info
could not be collected, because I'd have to force a reset either with
CTRL+ALT+DEL or by using a manual reset button. I'll see what happens when
Mozilla hangs again and I press CTRL+ALT+DEL again and then M (for Mozilla) and
then Enter to close Mozilla, as if the Task Manager program was active.

Chat sites/applets that I know are prone to hang Mozilla:
http://gay.com chat applet - you can access one from http://gayest.tripod.com .
There was also a Star Trek chat event with Casey Biggs (Damaron) around
28./29.03.2002., I tried to access it, but Mozilla seemed to crash. At least it
didn't react much and I had to force the closure (where the task manager said
that Mozilla was 'not responding') and I had to use Netscape 4.79 instead.

Mozilla 0.9.8 was also very prone to crash using the gay.com chat applet, but
0.9.6 and 0.9.7 were quite stable back (except for the bug in 0.9.7 that caused
a crash when requesting a context menu out of an imagemapped image) then and I
enjoyed using these. Hope 1.0 with a more stable JRE will be a great improvement
Hey, could we use an old JRE with Mozilla that Netscape 4.79 uses?

Comment 9

17 years ago
Mac bug, re-assign to Patrick.
Assignee: joe.chou → beard

Comment 10

17 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1) Gecko/20020826

I also have a problem with the http://www.gay.com chat app.  When the app tries
to load, Mozilla quits unexpectedly.  I'm running Mac OS X 10.2.

Comment 11

17 years ago
Posted file Chimera Crash log

Comment 12

17 years ago
Chris Petersen is a new QA contact for oji component. His email is:
petersen@netscape.com
Assignee: beard → petersen
fixing small error for pmac@netscape.com (filter with : SPAMMAILSUCKS)
Assignee: petersen → joe.chou
QA Contact: pmac → petersen

Comment 14

17 years ago
reassign to me
Assignee: joe.chou → joshua.xia

Comment 15

17 years ago
->Patrick
Assignee: joshua.xia → beard

Comment 16

17 years ago
->peterl
Assignee: beard → peterl
Priority: -- → P2
Target Milestone: --- → Future

Comment 17

16 years ago
Similar problem when attempting to enter Java cat room on Yahoo Groups.

When I click on the Chat link from any of the Yahoo! Groups pages, Mozilla
"winks out" every time without eception. 

Same behaviour is noted with ICQ2Go (http://go.icq.com).

Note this is on a pc, AMD k6-2 500, 256 Mb, Mandrake 9 with coustomized kernel

Updated

13 years ago
Blocks: 353557

Updated

13 years ago
No longer blocks: 353557
no reports in 5 years, marking wfm
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME

Updated

9 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.