Closed Bug 1300530 Opened 3 years ago Closed 2 years ago

"Edit As New" opens broken HTML Composition Window with missing contents, possibly add-on-related

Categories

(SeaMonkey :: MailNews: Composition, defect, major)

SeaMonkey 2.48 Branch
Unspecified
Windows 7
defect
Not set
major

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: RainerBielefeldNG, Unassigned)

Details

(Keywords: regression)

Attachments

(1 file)

Steps how to reproduce with official en-US SeaMonkey 2.48a1  (NT 6.1; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0 Build 20160904003221  (Default Classic Theme) on German WIN7 64bit

0. Create backup of your user profile → Dwonload installer.exe from
   <http://archive.mozilla.org/pub/seamonkey/nightly/> → Unzip → 
   Close running SeaMonkey → Launch new SeaMonkey with
   double click on seamonkey.exe in "core" folder
2. Launch Email Client (Is the first what will open for my SM)
3. In Thread Pane  ˋRightclick an arbitrary email in your main account
   Inbox → Edit As Newˊ (preferred: Preference "Compose as Plain Text,
   Email wiht attachment.PDF)
   » Mail Composer Window opens
   Expected: Text contents and attachment shown in normal looking
             Mail Composer Window
   Actual: no contents and recipient shown, attachment missing.
           No access to mail body composition by mouse click, 
           Composition window looks like broken HTML composition window
           (Smiley selector shown, no other style selectors)

a) this was still ok  with official en-US SeaMonkey 2.48a1  (NT 6.1; 
   WOW64; rv:51.0) Gecko/20100101 Firefox/51.0 Build 20160804000913
   (Default Classic Theme) on German WIN7 64bit
b) Problem persists with all add-ons disabled
c1) Problem vanishes in Safe mode
c2) I did not test with newly created profile. But an other new Problem
    Menu ˋTools → Web Development → Error consoleˊ shows "XML Parsing
    Error: undefined entity Location: 
    chrome://communicator/content/console/console.xul
    Line Number 86, Column 5:    <menubar id="main-menubar"
    ----^ " vanishes in safe mode and with new User Profile.
I can't reproduce that in 2.47a2 or 2.48a1.
User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0 SeaMonkey/2.47a2
Build identifier: 20160905024931
and
User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0 SeaMonkey/2.48a1
Build identifier: 20160905005658
Unable to confim with local en-US build and imap mailbox:

User agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:51.0) Gecko/20100101 Firefox/51.0 SeaMonkey/2.48a1
Build identifier: 20160905105310

c2) If latest Seamonkey please clear your cache. I removed the consoleoverlay files in Bug 1289794 and this might be some leftovers. If this doesn't help please file a new bug. If Seamonkey from Early August just ignore.
As stated this one probably is related to add-ons - or to that particular version.
this one will not be easy to confirm and it will be laborious to find the roots.
Whiteboard: [easyconfirm]
I would start with the latest build and check either the error or web console again. There should be something in the log for such a breakage.
NOT reproducible with unofficial en-US SeaMonkey 2.49a1  (NT 6.1; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0 Build 20160924050758  (Default Classic Theme) on German WIN7 64bit and the user profile which reproduced the problem with Build 20160904003221. I will test official 2.49 during weekend
NOT reproducible with unzipped installer of  official en-US SeaMonkey 2.53a1 (NT 6.1; WOW64; rv:56.0) Gecko/20100101 Firefox/56.0 Build 20170706013410  (Default Classic Theme) on German WIN7 64bit

WFM for now.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.