Closed Bug 1300581 Opened 6 years ago Closed 5 years ago

Selecting and dragging text shows other text as "dragged outline"

Categories

(Core :: DOM: Copy & Paste and Drag & Drop, defect, P3)

51 Branch
Unspecified
Windows
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
e10s ? ---
firefox48 --- wontfix
firefox49 --- wontfix
firefox50 --- fix-optional
firefox51 --- fix-optional

People

(Reporter: mayankleoboy1, Unassigned)

References

Details

(Keywords: correctness, steps-wanted, Whiteboard: [gfx-noted])

Attachments

(2 files)

Attached image bug.png
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20160903030202

Steps to reproduce:

1. Enable e10s on nightly on windows. Enable multiple content processes.
2. Enable APZC.
3. open a normal wikipedia page.
4. Open many links from that page which are long/complex *in background tabs*.
5. Switch to the newly opened tabs


Actual results:

If i double-click and select a word from the new page, and then drag it on the page, the "dragged-text-outline/shadow" shows some other text from the page.


Expected results:

not so.
*************************************************************
I have been seeing this bug for atleast a year, ever since APZ on windows became semi-useful on Nightly.  I have seen this bug on multiple systems (1 desktop, 2 laptops) all with different configurations, but with pretty modern and powerful hardware.

Ususlly to resolve this, i resize the browser window to a smaller size, and then maximize it again. 90% of the time, this bug gets fixed.

What i have noticed is that this usually happens when the links opened in background tabs are relatively "heavy" or "long". It has happened on bugzilla pages as well.
This is not 100% repro, but typically i see this atleast 2-3 times a browsing session of 2 hours.
tentative ni? based on the symptom.


NB: about a year back, when you could disable APZ, I tried doing it. After disabling I never could repro the issue. So I am pretty sure it has something to do with APZ. Hence the triage.
Flags: needinfo?(bugmail)
Thanks for filing. I'll try to repro. Can you confirm that all the affected systems you've seen this on were running Windows? Have you seen it on any other OS's?
Flags: needinfo?(bugmail)
OS: Unspecified → Windows
Priority: -- → P3
Whiteboard: [gfx-noted]
Version: Trunk → 51 Branch
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #2)
> Thanks for filing. I'll try to repro. Can you confirm that all the affected
> systems you've seen this on were running Windows? Have you seen it on any
> other OS's?

All systems were using Windows7 fully updated.
Can repro also on a Win10 Laptop.
I'm not able to reproduce this issue on my Windows machine using the STR given. Are you able to reproduce this with a single content process, or is multiple content processes necessary? The next time you see this, can you provide the specific URLs you saw it on?
Flags: needinfo?(mayankleoboy1)
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → INCOMPLETE
Flags: needinfo?(mayankleoboy1)
Sorry for not replying to this bug. The only reason i didnt reply was that the STR i gave is still not 100% reproducible. However, in my daily use, I encounter this bug multiple times.

Is there any other thing i can do here? Maybe you could give me a special build with some additional data collection, and when I reproduce this bug, I can create a data dump for you.
Flags: needinfo?(bugmail)
Please see comment 4. You don't need 100% reproducibility to answer those questions.
Flags: needinfo?(bugmail)
With only one content process, I still get the issue.
However, the frequency appears to be lesser. And typically, the fake outline vanishes after 1-2 retries of selecting text. With multiple content processes, i had to always resize the window to remove the fake outlines.

One URL is : http://www.bitsandchips.it/52-english-news/7588-amd-s-adventure-in-arm-world-seems-to-be-very-unlucky .  
But as I said in above comments, a specific URL doesnot appear to be related. It is more likely to be a "CPU starvation" from background tab loading.
Thanks. I'll poke around in the code and see if I can anything that might explain this. If I can come up with a theory as to what's going on then I can make a build with extra logging for you.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
Also in the meantime - Neil, do you know what might be causing this? I see you're tinkering with this code over in bug 1309596 - do you think that might fix this?
Flags: needinfo?(enndeakin)
It looks more like the generation of the image is incorrect which happens within nsDragServiceProxy::InvokeDragSessionImpl.

Is the incorrect feedback data generated from text on the same page but at the wrong position? Or is it coming from text from a different tab? If the former, the drag event's screen coordinates are used to determine where the drag feedback is generated from. Maybe these values are incorrect?

I assume that bug 1301673 did not fix this?
Flags: needinfo?(enndeakin)
(In reply to Neil Deakin from comment #10)

> 
> Is the incorrect feedback data generated from text on the same page but at
> the wrong position? Or is it coming from text from a different tab? 

It is text from the same page/tab. Typically, it is the text which i have selected on the same page previously. So typically:

1. Open tab A with some text Probably the tab has lots of data, and is vertically long. Select some text in it. Maybe drag it inside the tab only.
2. Open multiple tabs in background so that they use a lot of CPU
3. Scroll in tab A quickly up and down. 
4. Select some new text in tab A and drag it.

Actual Result: The outline of the text is the text previously selected in Step1.  
If after step 5, i select some other text, then teh outline is of the text selected in step5.



> I assume that bug 1301673 did not fix this?
No.
Component: Panning and Zooming → Drag and Drop
Attached image BUG_DRAG.png
bug 1309596 did not fix this.
This is with the latest Nightly
This happens very rarely nowadays.
I will close this for now. Will reopen if I get reliable STR or the bug becomes frequent again.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.