If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Build fails when error message includes umlauts

RESOLVED DUPLICATE of bug 1291843

Status

()

Core
Build Config
RESOLVED DUPLICATE of bug 1291843
a year ago
11 months ago

People

(Reporter: htcmaxx, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

16.41 KB, text/x-log
Details
7.45 KB, text/x-log
Details
(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160823121617

Steps to reproduce:

I followed the simple firefox build instructions here https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/Build_Instructions/Simple_Firefox_build and the windows prerequisites here https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/Build_Instructions/Windows_Prerequisites.

I created a file called "mozconfig" in the root of the mozilla-central source folder with the contents:

ac_add_options --target=x86_64-pc-mingw32
ac_add_options --host=x86_64-pc-mingw32

Then I started start-shell-msvc2015-x64.bat, changed the directory via cd to the mozilla-central source code root folder and ran ./mach build.


Actual results:

An error occured: UnicodeDecodeError: 'charmap' codec can't decode byte 0x81 in position 64: character maps to <undefined>.

I guess this error comes from handling the previous error message:

0:14.10 DEBUG: | c:\users\max0r\appdata\local\temp\conftest.m35ffp.cpp(1): fatal error C1083: Datei (Include) kann nicht ge�ffnet werden: "sys/byteorder.h": No such file or directory

It's german and should be "geöffnet" instead of "ge�ffnet".

When setting the language of Visual Studio 2015 to English, the build error disappears.

I attached the build log (via ./mach build > build.log) and the config.log from the obj-dir.


Expected results:

The error shouldn've occured.
(Reporter)

Comment 1

a year ago
Created attachment 8788276 [details]
config.log
(Reporter)

Comment 2

a year ago
Created attachment 8788277 [details]
build.log
(Reporter)

Updated

a year ago
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
(Reporter)

Comment 3

a year ago
I cannot edit my first comment so I'm gonna post a new one:

I said "When setting the language of Visual Studio 2015 to English, the build error disappears.". This is not true and I accidently included that sentence in the text - sorry for that. I'm currently remvoving my German installation of Visual Studio and after that I'm going to install the English version to verify that this bug does only appear using the German one.
There really are two problems here:
- The first one is that the check for sys/byteorder.h is not supposed to run for msvc, according to https://dxr.mozilla.org/mozilla-central/source/build/moz.configure/headers.configure#23
- The second is the UnicodeDecodeError, which should be handled more gracefully.
(Reporter)

Comment 5

a year ago
Just to confirm: I fully removed Visual Studio 2015 German, downloaded the English installer and installed the English version. After that, I could run mach without running into that UnicodeDecodeError.

Updated

11 months ago
Duplicate of this bug: 1309474

Updated

11 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1291843
You need to log in before you can comment on or make changes to this bug.