Closed Bug 1300762 Opened 4 years ago Closed 1 year ago

Wrong message displayed after FxA password reset

Categories

(Cloud Services :: Server: Firefox Accounts, defect)

defect
Not set
normal

Tracking

(firefox49 affected, firefox50 affected, firefox51 affected)

RESOLVED FIXED
Tracking Status
firefox49 --- affected
firefox50 --- affected
firefox51 --- affected

People

(Reporter: bogdan_maris, Assigned: pb)

Details

(Whiteboard: [fxa-waffle])

Attachments

(1 file)

[Affected versions]:
- Firefox 49.0 RC
- latest Developer Edition 50.0a2
- latest Nightly 51.0a1

[Affected platforms]:
- Ubuntu 16.04 32-bit
- Mac OS X 10.9.5
- Windows 10 64-bit

[Steps to reproduce]:
1. Visit about:preferences#sync
2. Click 'Sign In'
4. Click 'Forgot Password?'
5. Enter email and click 'Reset password'
6. Click rest password from Email client
7. Enter new Password in both 'New password' and 'Repeat password'
6. Click 'Submit new password'

[Expected result]:
- After step 6, Firefox automatically signs in and a sync is performed.

[Actual result]:
- User is not signed in into account and only 'Firefox Sync will begin momentarily' message is shown, which is confusing.

[Regression range]:
- I am unable to search for a regression due to the fact that this is a server side issue.

[Additional notes]:
- This issue is intermittent, I only reproduced 3/6 tries.
> only 'Firefox Sync will begin momentarily' message is shown, which is confusing.

This is super weird, as it means the browser *thinks* it's getting a valid login from sync.  Phil, does this sound like it might be related to the other intermittent login issues you've seen lately?
Flags: needinfo?(pbooth)
(In reply to Ryan Kelly [:rfkelly] from comment #1)
> Phil, does this sound like it might be related to the other intermittent login
> issues you've seen lately?

It's definitely possible. I'll try to reproduce it and debug then come back here to post my findings.
(In reply to Ryan Kelly [:rfkelly] from comment #1)
> Phil, does this sound like it might be related to the other intermittent login
> issues you've seen lately?

Yep, I have a strong hunch that this is related to:

https://github.com/mozilla/fxa-content-server/issues/4060

And I have an inkling that both might be caused by something similar to:

https://github.com/mozilla/fxa-auth-server/issues/1383

My clever plan to saturate the content server with extra logging around sign in etc has not worked so far. My next focus is on the session token object in the auth server.
Flags: needinfo?(pbooth)
Assignee: nobody → pbooth
Status: NEW → ASSIGNED
Whiteboard: [fxa-waffle]
Shane, given the localStorage theory in [1], do you think this could be due the reset-complete page trying to send the credentials across to the originating tab, but failing because they have different views of localStorage?

[1] https://github.com/mozilla/fxa-content-server/issues/4115#issuecomment-251862414
Flags: needinfo?(stomlinson)
localStorage shouldn't be at play in the communication here - browsers that support BroadcastChannel communicate using BroadcastChannel instead of localStorage.
Flags: needinfo?(stomlinson)

Is this issue still valid?

Flags: needinfo?(pbooth)

I don't recall seeing it happen in recent memory, closing.

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Flags: needinfo?(pbooth)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.