Always use 'old' debugger frontend in Browser Toolbox

RESOLVED FIXED in Firefox 51

Status

defect
P1
normal
RESOLVED FIXED
3 years ago
Last year

People

(Reporter: bgrins, Assigned: bgrins)

Tracking

unspecified
Firefox 51
Dependency tree / graph

Firefox Tracking Flags

(firefox51 fixed)

Details

Attachments

(2 attachments)

At least as of a build today, the new frontend breaks upon loading in BT.  On top of this, it's hard to manually flip prefs in BT profile (can't easily load about:config) so we can't give people a quick workaround to load the old forntend in case something breaks.

I suggest we flip the 'devtools.debugger.new-debugger-frontend' pref to false here: https://dxr.mozilla.org/mozilla-central/source/devtools/client/framework/toolbox-process-window.js#65
Posted image bt-error-message.png
Just for reference, here's a screenshot of the error I saw at startup: ReferenceError: promise is not defined panel.js:17:7
Assignee: nobody → bgrinstead
Status: NEW → ASSIGNED
Priority: -- → P1
Comment on attachment 8788577 [details]
Bug 1300820 - Always use the current debugger frontend in Browser Toolbox;

https://reviewboard.mozilla.org/r/77016/#review75230

Awesome!
Comment on attachment 8788577 [details]
Bug 1300820 - Always use the current debugger frontend in Browser Toolbox;

https://reviewboard.mozilla.org/r/77016/#review75232
Attachment #8788577 - Flags: review?(jlong) → review+
Pushed by bgrinstead@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/17f792799636
Always use the current debugger frontend in Browser Toolbox;r=jlongster
Duplicate of this bug: 1300865
https://hg.mozilla.org/mozilla-central/rev/17f792799636
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.