Last Comment Bug 130083 - unable to print on Win 98/ME with default spool setting
: unable to print on Win 98/ME with default spool setting
Status: RESOLVED WORKSFORME
: relnote
Product: Core
Classification: Components
Component: Printing: Output (show other bugs)
: Trunk
: x86 Windows 98
: P3 normal with 7 votes (vote)
: Future
Assigned To: Simon Montagu :smontagu
: sujay
Mentors:
: 86989 167760 (view as bug list)
Depends on:
Blocks: 125824
  Show dependency treegraph
 
Reported: 2002-03-11 10:19 PST by sujay
Modified: 2008-07-17 06:33 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description sujay 2002-03-11 10:19:14 PST
using 3/11 trunk build on Win 98/ME

1) launch netscape
2) print any web page

unable to print

workaround = go into printer properties, choose details tab, choose
spool settings, choose print directly to printer.

then it works.
Comment 1 sujay 2002-04-03 11:27:51 PST
nominating...

random users are experiencing this...
Comment 2 dcone (gone) 2002-04-03 13:28:13 PST
I dont think this should be a nsbeta1.. there is a work around.. its not a very 
common thing to happen.. and it could take a long while to find.. since its very 
hard to reproduce.  I have never been able to reproduce this problem.
Comment 3 sujay 2002-04-09 14:37:50 PDT
*** Bug 86989 has been marked as a duplicate of this bug. ***
Comment 4 Kevin McCluskey (gone) 2002-04-11 14:26:27 PDT
nsbeta1-. Hard to reproduce, only affects 98/ME when spooling is turned on
(local spooling) which is not normally the default.
Comment 5 Wesley Crossman 2002-05-12 02:06:08 PDT
Hard to reproduce? I have been experiencing this error consistently with my 
Lexmark printer, and spooling IS turned on by default (with Lexmarks at least). 
This bug also makes the whole computer unstable. Turning it off allowed Mozilla 
to print (sans Lexmark control panel), but it totally ignored my printing 
preferences (In Print...|Properties). This bug would make it impossible for the 
average Lexmark user to print, so I hope this will get fixed before 1.0. It is 
a real nuisance, to me at least. BTW, I am running Windows 98 SE with 1.0 beta 
2. I have printed before with this exact setup, so it is something that broke 
around a month ago.
Comment 6 sujay 2002-05-13 10:30:52 PDT
renominating...Kevin, it seems like this is easy to reproduce if you have
this configuration.
Comment 7 Kevin McCluskey (gone) 2002-06-25 14:54:16 PDT
sujay: There have been alot of printing changes and fixes put onto both the
trunk and 1.0 branch over the last few weeks. Is this bug still a happening on
the branch? Don can not reproduce.
Comment 8 Colin Tuckley 2002-07-26 04:36:37 PDT
The workaround does NOT work on my system with mozilla 1.1 Beta.

The problem is intermitant and appears to be related to page size/complexity.

Also and more important in some ways, if the printer is shared on a network than
win98SE will NOT allow you to turn off the spooling!
Comment 9 John R. Long 2002-09-09 15:21:20 PDT
I never seen this bug before with an hp1100 ptr from .97 thru 1.1B, replaced
1100 ptr with am hp1200 30 days ago and still fine. On 9-1-02 installed 1.1 rel
and have had this darn locking spool prob since.

My ptr has always been shared and cannot be set for direct print. If I unshare
then direct then reshare it goes back to spool and gray direct box.

I have to close Moz and then it prints. Big problem if I have several tabs open...
Comment 10 Steven Frank 2002-09-10 09:05:19 PDT
I have had this same problem since 1.1A on *Windows 2000* with a local (and not
shared) printer (HP v40xi, w/USB). I am now using 1.1, and the problem persists.
It is not intermittent. Can't print from Browser or MailNews.

The workaround does work, but it is very inconvenient.
Comment 11 alain 2002-09-13 15:29:55 PDT
I confirm this spooling problem with win98 + HP Deskjet 710C
Motzilla 1.1a
Comment 12 Kevin McCluskey (gone) 2002-11-13 17:56:17 PST
nsbeta1+
Comment 13 Athanassios Protopapas 2002-11-20 06:02:20 PST
This is not an intermittent bug.  I am entirely unable to print on any of the
network printers (only network printers are available) regardless of the spool
settings.  Mozilla 1.2beta on Win98 connected to HP Laserjets using JetDirect
administration.  Source (web page or e-mail message text) does not matter --
"the printer cannot be found" comes up as soon as "Print..." is selected.  VERY
annoying.
Comment 14 Kurt Dermen 2003-01-01 11:35:36 PST
Just wondering....  The previous comment (#13) is consistent with this bug being
same as or very similar to bug #181213, which I reported.  To reiterate, the
workaround does NOT work, and I can't print anything from the browser (applies
to past several releases).  Unfortunately, this makes browser almost useless. 
There is nothing special about my system or setup, as far as I can tell.  Please
let me know if I can provide any more info that might help you fix this bug.
Comment 15 Kevin McCluskey (gone) 2003-01-22 17:08:10 PST
-> smontagu. Dividing up Don's nsbeta1+ bugs.
Comment 16 Athanassios Protopapas 2003-02-12 12:04:54 PST
Problem still persisting with 1.3b on Windows 98.  Cannot print anything at all
(this is sufficient reason to abandon Mozilla altogether -- please commit to
resolution for 1.3 final release).  Behavior as described above in #13. 
PURPORTED WORKAROUND DOES *NOT* WORK.
Comment 17 Kevin McCluskey (gone) 2003-03-21 14:29:58 PST
*** Bug 167760 has been marked as a duplicate of this bug. ***
Comment 18 Don Jarrell 2003-05-31 14:56:41 PDT
please forgive: newbie - not a programmer - good heuristic observer/analyst

problem may have specific content trigger and/or be related to pagination

- tried to print http://kenradio.com/reports/may30-03.htm
- browser appeared to lock up requiring forced End
- re-started Moz 1.2.1 (Gecko/20021130 - let me know if I'm not giving right
  info) on Win98 SE + patches (4.10.2222 A)
- tried printing again; same page; should be about 3 printed pages
- apparent stall of some kind; spooler showed staus Printing  0 of 139 pages !!!
- Moz, spooler and printer driver Not Responding
- re-booted

===  Since that time any attempt to print a web page from Moz resulting in >1 
     printed page yields simlar results (single page prints OK: 
     spooler status=Printing but no output forever; spooler Not Responding, 
     blocks Moz; printer driver starts and stops but never prints anything
NO printing trouble with any other applications.

That's it; first post; flame away.
  
Comment 19 Linda Turner 2003-12-12 09:10:26 PST
I have also been experiencing this error consistently with my 
Lexmark printer in Windows 98 SE, and the spooling is turned on by default. 
This bug also makes my printer unusable so I have to reboot. 
I tried this workaround = go into printer properties, choose details tab, choose
spool settings, choose print directly to printer.  The printer doesn't work at
all with this setting.
I have to highlight whatever I want printed and print selection.  This works for me.
Comment 20 Tom Campbell 2004-02-27 16:53:58 PST
Additional notes on XP:

I have the same problem on my Windows XP Pro system when printing to an HP
LaserJet 4050N. I was able to fix the problem by turning off spooling as the bug
report suggested, though due to UI changes I had to do it like this:

Control Panel > Printers and Faxes > HP LaserJet 4050N > Properties > Advanced >
Print Directly to Printer [check this]
Comment 21 Wayne Mery (:wsmwk, NI for questions) 2006-04-23 13:32:52 PDT
hasn't this gone away?
Comment 22 Jacek Piskozub 2006-04-23 13:58:43 PDT
I haven't seen it for years. And I still use various versions of mozilla.org browsers on Win9x. 

Marking WORKSFORME.
Comment 23 Matthias 2008-07-17 06:33:27 PDT
I have the same problem on Win XP SP3 with Seamonkey 1.1.11 and previous versions. It doesn't seem to depend on the printers which are installed on the machine.

Note You need to log in before you can comment on or make changes to this bug.