Scrolling page causes incorrect repaint of images

RESOLVED DUPLICATE of bug 121230

Status

()

Core
ImageLib
RESOLVED DUPLICATE of bug 121230
16 years ago
16 years ago

People

(Reporter: Thomas Swan, Assigned: Stuart Parmenter)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

16 years ago
This is a regression, however I first noticed it at least a month or two ago,
but could never reproduce it until now.  This happens particularly with PNGs
although I don't believe that it is limited to them (at least from what I have
experienced.)

Steps to reproduce.

1. Load the above URL.
2. Scroll the page up and down rapidly.

Alt+Tabbing to a window that overlaps the area and the Alt+Tabbing back to
Mozilla will show a correctly painted image.

Reproducable: Always

Observation: 
The image is wrapped vertically (depending on the time of repaint.)

Details:
Mozilla Win32 Nightly Build - 2002031103 (latest-trunk)
Video: 1280x1024x16bpp (Win2K)
(Reporter)

Comment 1

16 years ago
Created attachment 73529 [details]
Correctly painted

Shows correct (expected) rendering of image
(Reporter)

Comment 2

16 years ago
Created attachment 73530 [details]
Incorrectly Painted

Shows result from scrolling
(Reporter)

Comment 3

16 years ago
Created attachment 73531 [details]
Another different rendering

Shows another (different) result from scrolling
(Reporter)

Comment 4

16 years ago
Created attachment 73532 [details]
Another different rendering

Shows another (different) result from scrolling

*** This bug has been marked as a duplicate of 83289 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 6

16 years ago
Are you sure this is a duplicate?

Comment 7

16 years ago
This definitely isn't a duplicate.  If you actually look at the screenshots,
it's a totally different bug.  This one is causing the images to wrap
vertically, the other one was causing white stripes.
(Reporter)

Comment 8

16 years ago
Based on Comment #7
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Maybe related to bug 128179 or bug 121230?

Comment 10

16 years ago
If it's worth a "me too" comment, I was just about to report this too in 2002030803.

(Loading http://thurman.org.uk/thomas/pics/polygons/test and scrolling down to
the bottom looks like http://thurman.org.uk/thomas/pics/polygons/bugzilla ;
making Mozilla repaint, by switching to another application and back, shows it
correctly.)

Updated

16 years ago
Blocks: 134942

Comment 11

16 years ago

*** This bug has been marked as a duplicate of 121230 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 12

16 years ago
No this is not the same. Bug 121230 deals only with PNG images.  This problem
also occurs with GIFs and JPEGs.

Updated

16 years ago
No longer blocks: 134942
You need to log in before you can comment on or make changes to this bug.