"Clear private data" from menu should work on 7.0

RESOLVED DUPLICATE of bug 818994

Status

()

--
major
RESOLVED DUPLICATE of bug 818994
2 years ago
2 years ago

People

(Reporter: alex.caziuc, Unassigned)

Tracking

(Blocks: 1 bug)

49 Branch
All
Android
Points:
---

Firefox Tracking Flags

(firefox49 affected, fennec+)

Details

(Reporter)

Description

2 years ago
Tested using: Nexus 6P(7.0) on Beta 49.0b11

Steps:
1. Have some websites in History
2. Go to menu -> Clear private data(check mark all boxes or just history doesn't matter)

Actual result:
'Private data cleared' appears but nothing happens

Expected result:
The history tab should be empty(deleted)

Note: 
1.Clear browsing history from history tab works
2.Enabling "Clear private data on exit" and tap quit works
3.Also clean profile from android works(it creates clean profile)
(In reply to Alex Caziuc from comment #0)
> 2. Go to menu -> Clear private data(check mark all boxes or just history

You mean the option in settings?
(Reporter)

Comment 2

2 years ago
Yes it's the option in settings: Settings -> Clear private data
tracking-fennec: --- → ?
OS: Unspecified → Android
Hardware: Unspecified → All
Word on the street is that we've had this for a while and it's intermittent. If that's not the case (if it happens every time), we should revisit.
tracking-fennec: ? → +
See Also: → bug 1052391
I can reproduce it with "Don't keep activities" enabled in the developer settings.

> GeckoConsole  E  [JavaScript Error: "Java-side history clearing failed: No listeners for request" {file: "resource://gre/modules/Sanitizer.jsm" line: 148}]
> E  Sanitizer.prototype.items.history.clear/<@resource://gre/modules/Sanitizer.jsm:148:23

[..]
Which is bug 818994
Is "Don't keep activities" enabled on your device?
Flags: needinfo?(alex.caziuc)
(Reporter)

Comment 7

2 years ago
I tried it with "Don't keep activities" disabled and it works as it should(clears history,etc). So I will make it a duplicate of bug 818994.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(alex.caziuc)
Resolution: --- → DUPLICATE
Duplicate of bug: 818994
You need to log in before you can comment on or make changes to this bug.