Closed Bug 1301053 Opened 3 years ago Closed 2 years ago

A misleading error is received before playing an HLS video

Categories

(Firefox for Android :: Audio/Video, defect, P2)

ARM
Android
defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox48 --- unaffected
firefox49 --- unaffected
firefox50 --- affected
firefox51 --- affected

People

(Reporter: u549602, Unassigned)

References

Details

(Keywords: qablocker)

Attachments

(1 file)

Environment: Aurora (50.0a2)
Device: Samsung Galaxy S6 Edge (Android 5.1);
Build: Aurora 50.0a2 (2016-09-07);

Steps to reproduce:
1. Go to goo.gl/LLxEY8 and play the video

Expected result:
The video plays correctly and no error should be shown

Actual result:
An error is displayed before actually playing the video, which can be misleading for the user since the error states that the Video is not supported 

If the user waits a few moments, the HLS player pops and the video is played

Note : This issue occurs on all devices and Android versions

For further details please check : https://www.youtube.com/watch?v=YeMDArjr9po&feature=youtu.be
Depends on: 1301055
Priority: -- → P2
Hello Mihai, is this a 100% repro? I am just trying to determine how often will a user encounter this problem. Does it affect video playback on youtube only or FB or netflix etc? Thanks!
Flags: needinfo?(mihai.ninu)
None* of those sites use HLS video for Firefox. The sites that provide HLS only tend to be news sites or small to medium video streaming sites. 

* Facebook uses HLS for their live streaming feature, YouTube may serve HLS to iPhones/Safari
Hi Ritu,

I can confirm what Kevin said in the comment above, Youtube,Facebook are not affected by this, this issue occurs only on sites that use HLS videos.
On those sites that do use HLS videos, the error is present with a 100% repro rate before actually playing the HLS video. The presence of the error on the screen in time may vary due to the loading times and video.
Flags: needinfo?(mihai.ninu)
The error before playing the video is no longer present now that bug XXX has been fixed, but there is an error that appears in the media element while you're playing the video in the VideoView (and that is still there once you close the VideoView).
This makes the video not replayable.
(In reply to Marco Castelluccio [:marco] from comment #4)
> bug XXX

Bug 1301055.
(In reply to Marco Castelluccio [:marco] from comment #4)
> Created attachment 8814501 [details]
> Screenshot_20161125-222828.png
> 
> The error before playing the video is no longer present now that bug XXX has
> been fixed, but there is an error that appears in the media element while
> you're playing the video in the VideoView (and that is still there once you
> close the VideoView).
> This makes the video not replayable.

I filed bug 1321243 for this.
No longer reproducible in nightly/59 for bug 1345752 deprecated HLS VideoView.
Status: NEW → RESOLVED
Closed: 2 years ago
Depends on: HLS_on_Fennec
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.