Closed Bug 1301147 Opened 3 years ago Closed 3 years ago

Use BrowserLoader require in new debugger so we can share frontend modules

Categories

(DevTools :: Debugger, defect)

defect
Not set

Tracking

(firefox51 fixed)

RESOLVED FIXED
Firefox 51
Tracking Status
firefox51 --- fixed

People

(Reporter: jlong, Assigned: jlong)

References

Details

Attachments

(1 file)

Right now it just uses the devtools require, but that means we can't share the React library. We want to do that so we can remove a lot of duplicated code and make sure everyone's component are inter-operable.
Blocks: 1294139
Attached patch 1301147.patchSplinter Review
Pushed by jlong@mozilla.com:
https://hg.mozilla.org/integration/fx-team/rev/fb737d495a79
use browser loader in new debugger r=me
Assignee: nobody → jlong
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/fb737d495a79
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.