Closed Bug 130118 Opened 18 years ago Closed 18 years ago

text/calendar is displayed instead of text/html for multipart/alternative messages

Categories

(MailNews Core :: MIME, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 83262

People

(Reporter: jmdesp, Assigned: bugzilla)

Details

Attachments

(1 file)

When a multipart/alternative has both text/html and text/calendar content,
Mozilla displays the text/calendar instead of text/html.

text/calendar (generated by the Outlook calendar) is not a known type to Mozilla
and it does not know how to display it properly.

Mozilla should favor types it knows to type if doesn't know, and display the
text/html intead of the text/calendar.

Step for reproduction :
 - display the mail message that I include as an attachment.
this is a dup of bug 83262 which has been fixed last week. Please try with a
recent build. BTW, which build are you using?

*** This bug has been marked as a duplicate of 83262 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
I'm using :
Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.9) Gecko/20020311

If it has been resolved, then it hasn't been checked in the 0.9.9 branch.

Bug 83262 is "Scrollbar on preferences dialog doesn't sync" and has no
relationship with this problem, maybe one of the digits is wrong.

I tried hard to find a duplicate, and even did some searches on closed bugs, but
did not see one.
Right, the fix it's only on the trunk (1.0)
Product: MailNews → Core
Product: Core → MailNews Core
Pushed by bkelly@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/4b66e6bb1db8
P2 Make TaskQueue implement nsIEventTarget. r=bholley
You need to log in before you can comment on or make changes to this bug.