Intermittent toolkit/components/url-classifier/tests/mochitest/test_gethash.html | Test timed out.

RESOLVED FIXED in Firefox 50

Status

()

defect
P2
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: intermittent-bug-filer, Assigned: dimi)

Tracking

({intermittent-failure})

unspecified
mozilla52
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox50 fixed, firefox51 fixed, firefox52 fixed)

Details

Attachments

(1 attachment)

Dimi, is this something that should be fixed by your recent fixes to the tests?
Flags: needinfo?(dlee)
Priority: -- → P1
It doesn't look like any of the problem solved recently.
I will check this.
Assignee: nobody → dlee
Status: NEW → ASSIGNED
Flags: needinfo?(dlee)
I found the error occurs whiles regular update[1] happens when running test_gethash.html.
I am still investigating why it breaks test_gethash.

[1]https://dxr.mozilla.org/mozilla-central/source/toolkit/components/url-classifier/content/listmanager.js#248
Priority: P1 → P2
just an update that regular update may block test_gethash update[1], but for some reason the update retry[2] is not triggered so the testcase fail.

I'll keep checking.

[1] https://dxr.mozilla.org/mozilla-central/source/toolkit/components/url-classifier/nsUrlClassifierDBService.cpp#1575
[2] https://dxr.mozilla.org/mozilla-central/source/toolkit/components/url-classifier/tests/mochitest/classifierCommon.js#48
Sorry for not updating this bug for a while, the reproduce rate is really low so it did take more time to debug this.

What I have found so far is that the retry timer is released before triggering retry. I guess it might be related to the timer life cycle in javascript. I will keep working on this bug.
After investigating, I think the root cause is that sometimes the timer is released by gc before it is fired.

Following is try result after applying the patch, i think it should be fixed because i have run the test more than 10000 times and it didn't happen again.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=76a5cc7d87f0&selectedJob=29618760
Comment on attachment 8803239 [details]
Bug 1301269 - Fix update retry timer is released before firing.

https://reviewboard.mozilla.org/r/87564/#review87408
Attachment #8803239 - Flags: review?(francois) → review+
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/382894f45be6
Fix update retry timer is released before firing. r=francois
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/382894f45be6
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
I apparently forgot to mark the bug when uplifting this to Beta a couple weeks ago.
https://hg.mozilla.org/releases/mozilla-beta/rev/52b776e91075
You need to log in before you can comment on or make changes to this bug.