[gtk3] GTK_CSD=1 not generating client side decorations on FF

RESOLVED DUPLICATE of bug 1283299

Status

()

P4
enhancement
RESOLVED DUPLICATE of bug 1283299
2 years ago
2 years ago

People

(Reporter: j.e.vasquez.v, Unassigned)

Tracking

48 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: tpi:+)

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8789201 [details]
midori_gtk3_csd.gif

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160824215626

Steps to reproduce:

Being using FF 48.0.2 on Arch, compiled against gtk3, I was expecting by setting GTK_CSD=1 to get a FF without a title bar, and with minimize, maximize and close buttons inside FF (right upper corner but within FF) rather than the buttons in the title bar which shouldn't show up any more...

The attached file midori_gtk3_csd.gif shows a similar gtk3 application with CSD working...


Actual results:

Well, the title bar is there (didn't go away), and the min/max/close buttons are not inside FF but rather in the title bar.
(Reporter)

Comment 1

2 years ago
Created attachment 8789202 [details]
ff_gtk3_csd.gif
(Reporter)

Comment 2

2 years ago
The attached ff_gtke_csd.gif shows how actually FF doesn't work as expected with GTK_CSD=1, including the title bar, and having the min/max/close buttons in it, rather than FF itself...

Updated

2 years ago
Component: Untriaged → Widget: Gtk
Product: Firefox → Core

Updated

2 years ago
Blocks: 627699

Comment 3

2 years ago
I could be wrong but GTK_CSD=1 doesn't magically create a CSD interface.
It doesn't do anything for applications not using CSD to begin with (evolution, firefox, libreoffice, etc...)
(Reporter)

Comment 4

2 years ago
Well, it's supposed to remove the title bar AFAIK:

https://wiki.archlinux.org/index.php/GTK%2B#Client-side_decorations
https://blogs.gnome.org/mclasen/2013/12/05/client-side-decorations-in-themes

And several applications like midori, gnome-mpv, and others are taking advantage of that...  To me it sounds like the expected behavior is to remove the title bar.  The minimize/maximize/close buttons are expected to be included by the application itself, which is what client side decorations means any ways, or at least I thought it meant...  BTW, FF is already doing that on its ms-windows version.

And supposedly by setting GTK_CSD=1 one is indicating to gtk3 based applications that one is expecting client side decorations to be used by them, :-)

Updated

2 years ago
Severity: normal → enhancement
Priority: -- → P4
Whiteboard: tpi:+
The title and the description of this report are describing different things.

With GTK_CSD=1, the GTK in client app (instead of the window manager) draws the title bar with buttons.  If it is doing this well then you won't notice the difference, but typically you do because the client doesn't respond to mouse input like the window manager does.  e.g. as with Matthias indicates with Ambiance, the window can't be resized or moved from the border.

What the description is requesting is that the client draw something quite different to what the window manager would draw.

I suspect this will be resolved through changes proposed in bug 1283299.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1283299

Comment 6

2 years ago
(In reply to Karl Tomlinson (:karlt) from comment #5)
> With GTK_CSD=1, the GTK in client app (instead of the window manager) draws
> the title bar with buttons.  If it is doing this well then you won't notice
> the difference
In this case, this probably works. GTK+ draws deeper shadows arounds the borders than mutter does.
With GTK_CSD=1 firefox, I actually see deeper shadows.
You need to log in before you can comment on or make changes to this bug.