Expand selected sub-tree into higher level (Explode folder)

NEW
Unassigned

Status

SeaMonkey
Bookmarks & History
--
enhancement
19 years ago
6 years ago

People

(Reporter: CodeMachine, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [2012 Fall Equinox])

(Reporter)

Description

19 years ago
The following would be useful bookmark management capabilities.

Export A SubTree To A File
Import A File Into A SubTree
Expand A SubTree Into The Above Level
Collapse The Selected Bookmarks Into A SubTree

Updated

19 years ago
Severity: normal → enhancement

Comment 1

19 years ago
Don, an RFE. Please re-assign or later as appropriate.

Updated

19 years ago
Summary: Advanced bookmarking capabilities → [RFE] Advanced bookmarking capabilities
Target Milestone: M14

Updated

19 years ago
Component: Browser-General → Bookmarks
QA Contact: leger → claudius

Comment 2

19 years ago
Updating QA Contact/component.

Comment 3

19 years ago
Move to M20.

Comment 4

19 years ago
Implementation suggestions ...

To export a folder to a file:
* select the folder;
* choose `File' > `Save';
* from the `Save' popup menu in the save dialog, choose `selected bookmark(s)'
  (the popup menu defaults to `whole bookmarks file').
This would work even if you wanted to save more than one folder at once.

To import a file into a folder:
* select `File' > `Import ...';
* choose `From File ...' in the Import dialog;
* from the `Import as' popup menu in the file dialog, choose `new folder' (the
  popup menu defaults to `whole bookmarks file');
* once the import has finished, enter the name for your new folder.

Or, a quicker way:
* drag the icon for the file into the bookmarks window;
* once the import has finished, enter the name for your new folder.

To expand a folder's contents into the next highest level:
* select the folder
* choose `Explode folder(s)' from the Edit menu.
... Or maybe not. :-)

To collapse the selected bookmarks (and/or folders) into a folder:
* select the bookmarks (and/or folders);
* open the `File' > `New' submenu, and note that the usual `Folder'
  (Ctrl+Shift+N) item has changed to `Folder for Selected Items';
* select `Folder for Selected Items';
* enter the name for your new folder.

All of these should work for ordinary directories in the browser too, if/when 
Navigator's directory listing becomes capable of editing the directory contents.

Resumarizing -- there are a lot of RFEs for `Advanced bookmarking capabilities' 
in general, but this one is about filing in particular.
Summary: [RFE] Advanced bookmarking capabilities → [RFE] Advanced bookmark filing capabilities

Comment 5

18 years ago
Move to "Future" milestone.
Target Milestone: M20 → Future
Since Don has left, Vishy is taking his bugs in bulk, pending reassignment.
thanks,
	Vishy
Assignee: don → vishy

Comment 7

18 years ago
UI input given (unless Matthew has changed his mind, which I've seen happen ), 
-> bookmarks
Assignee: vishy → ben

Comment 8

17 years ago
Should the bug summmary be changed to:
[RFE] Advanced bookmark import/export and bookmark subtree expand/collapse
?
mpt-
I like the "Folder for Selected Items" thing, but the other descriptions are
incomplete (you only describe parts of features). Care to produce something more
complete? ;)
Status: NEW → ASSIGNED
Priority: P3 → P4
Paul Chen is now taking Bookmarks bugs. For your convenience, you can filter 
email notifications caused by this by searching for 'ilikegoats'.

Assignee: ben → pchen
Status: ASSIGNED → NEW

Comment 11

17 years ago
mass reassign of pchen bookmark bugs to ben
Assignee: pchen → ben

Comment 12

16 years ago
Export A SubTree To A File
--> bug 114592

Import A File Into A SubTree
--> bug 137568

Expand A SubTree Into The Above Level

Collapse The Selected Bookmarks Into A SubTree
--> select, "file bookmarks"
Summary: [RFE] Advanced bookmark filing capabilities → Expand selected sub-tree into higher level (Explode folder)
Product: Browser → Seamonkey
Assignee: bugs → nobody
QA Contact: claudius → bookmarks

Comment 13

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 14

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 15

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 16

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 17

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 18

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 19

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 20

8 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → EXPIRED

Comment 21

8 years ago
Valid enhancement requests.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: EXPIRED → ---

Updated

8 years ago
Status: REOPENED → NEW

Comment 22

6 years ago
Still valid rfe
Priority: P4 → --
Whiteboard: [2012 Fall Equinox]
You need to log in before you can comment on or make changes to this bug.