Closed Bug 1301338 Opened 6 years ago Closed 5 years ago

Plain text files are rendered with a monospace font instead of the selected font in reader view

Categories

(Toolkit :: Reader Mode, defect)

50 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1154295

People

(Reporter: bz, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20160907004009

Steps to reproduce:

* Visited a page which is served with a Content-Type of text/plain such as https://raw.githubusercontent.com/Storyyeller/Krakatau/master/Documentation/assembler.txt

* Click the "Reader View" button in the URL bar

* Confirmed that "Sans Serif" was selected in the font-type-buttons reader-popup

* Looked at the document


Actual results:

* The text was rendered with a monospaced font, maybe due to the specificity of the "font-family: -moz-fixed;" rule from the browser's styles vs the "font-family: Helvetica, Arial, sans-serif;" on body.sans-serif.


Expected results:

* The text should've been rendered with the selected font, in my opinion.
Component: Untriaged → Reader Mode
Product: Firefox → Toolkit
I get similar results in 50.1.0 in MacOS. What does it take to confirm a bug?
This is because Firefox renders pages with text content in them like this: <pre>The contents of the file</pre> 

This doesn't get removed by Readability.js apparently and then gets put into the reader mode display.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1154295
You need to log in before you can comment on or make changes to this bug.