[EME] Manually forwarding the video to it's end, gives an error which is thrown on top of the video

NEW
Unassigned

Status

()

P3
normal
2 years ago
2 years ago

People

(Reporter: ciprian_georgiu, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox48 unaffected, firefox49 affected, firefox50 affected, firefox51 unaffected)

Details

Attachments

(1 attachment)

Created attachment 8789430 [details]
forward issue eme.gif

[Note]:
- .gif showing the issue

[Affected versions]:
- latest Aurora 50.0a2 (2016-09-07) 
- Firefox 49.0b10
- Firefox 49.0

[Unaffected versions]:
- latest Nightly 51.0a1 (2016-09-07)
- Firefox release 48.0.2

[Affected platforms]:
- Ubuntu 16.04 LTS x64
- Windows 10 Pro x64
- macOS Sierra 10.12 Beta 

[Steps to reproduce]:		
1. Launch Firefox.
2. Go to http://goo.gl/0cVfha.
3. From drop-down Asset menu choose "Sintel 4k (multicodec, Widevine)", then click Load.	
4. Manually forward the video to it's end.

[Expected result]:
- The video ends (if Loop option is enabled, the video starts all over again).

[Actual result]:
- An error is thrown on top of the video: Shaka Error MEDIA.MEDIA_SOURCE_OPERATION_THREW (InvalidStateError: An attempt was made to use an object that is not, or is no longer, usable).

[Regression range]:
- This is not a regression.

[Additional notes]:
The error is also displayed for: 
- "Angel One (multicodec, multilingual, Widevine)" 
- "Dig the Uke" by Stefan Kartenberg (audio only, multicodec, Widevine)
- WebM source 
- MP4 only source from Asset menu.

   Note: this is the same error filled in the bug 1298027.
Marking as P3 because it isn't filed against a production site and it is fixed in 51 anyway.
Priority: -- → P3
Assignee: bvandyk → nobody
You need to log in before you can comment on or make changes to this bug.