installer doesnt work, error messages xpi not installed

VERIFIED WORKSFORME

Status

--
blocker
VERIFIED WORKSFORME
17 years ago
14 years ago

People

(Reporter: djcovey, Assigned: slogan)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.0.3 (X11; Linux i686; U;) Gecko/20020205
BuildID:    2002031100

the mozilla installer will not work.  Get error message saying "an installer
module xxxx.xpi failed to install"

Reproducible: Always
Steps to Reproduce:
1.Download todays build for 0.9.9
2.Ungzip it, untar it.
3.run installer

Actual Results:  installer starts, but when it gets to installing the xpi's, all
that happens is error messages, error 621.

Expected Results:  mozilla gets installed and the runs

I've been having this trouble for a couple of days now.
Need more info about why it would fail for you and not hundreds of other 
people. Machine/OS specifics? Could you pin down "a couple of days"?

Could you be having the same system problem as in bug 109409?

Assignee: dveditz → syd

Updated

17 years ago
QA Contact: bugzilla → ktrina

Comment 2

17 years ago
isn't this "works for me"

Comment 3

17 years ago
marking WORKSFORME based on lack of reporter's reply and lack of ways to reproduce.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 4

17 years ago
Verified works for me. Reporter, please reopen if problem still occurs (and
please include machine/OS specifics).
Status: RESOLVED → VERIFIED

Comment 5

17 years ago
I had the same problem. The install.log contains the following lines:

file:///opt/mozilla/mozilla-installer/./xpi/browser.xpi
Install **FAILED** with error -207  --  07/10/2002 08:12:26

I was able to unzip the file `browser.xpi' manually, so there is no
problem in that regard.

Could this have to do with an environment variable that is not set?
Or could the installer be assuming, in some part of it, a specific
installation directory such as `/usr/mozilla' or `/usr/local/mozilla'
or something like that, rather than the non-standard `/opt' which I
am using?

I am running Red Hat 6.1, kernel version: 2.2.12-20, processor
Pentium 233-MMX, 96 MB RAM, plenty of disk space:
$ df /opt
Filesystem           1k-blocks      Used Available Use% Mounted on
/dev/hdc8               995115    488292    455417  52% /

I'd probably be able to figure it out if the entire installer
were a shell script, but it looks like it's not:

$ file mozilla-installer-bin
mozilla-installer-bin: ELF 32-bit LSB executable, Intel 80386, version 1,
dynamically linked (uses shared libs), not stripped

Any help would be appreciated.

Thank you,

Tom
mozilla@hedden.org

(Reporter)

Comment 6

17 years ago
Re-opening as Thomas is now experiencing the same problem.  See his comment for
details.
Status: VERIFIED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 7

17 years ago
It doesn't seem likely that Thomas is seeing the original problem here, but...

I don't see anywhere in the code that could have produced the message:
Install **FAILED** with error -207  --  07/10/2002 08:12:26

the closest thing is error -1207, but I don't see how that could get printed to
the console.  Are you sure that's the exact error?
Does this problem still exist? I don't think so, if not please resolve it.
(Reporter)

Comment 9

16 years ago
Resolving as Worksforme.  Haven't been able to reproduce this for a long time.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → WORKSFORME
V. it per Comment 9
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.