Bug 130161 (txxhtml)

html is emulated using xhtml

VERIFIED FIXED in mozilla1.2beta

Status

()

Core
XSLT
VERIFIED FIXED
16 years ago
15 years ago

People

(Reporter: sicking, Assigned: sicking)

Tracking

Trunk
mozilla1.2beta
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

We currently emulate html by creating xhtml elements. We also always use an 
nsXMLDocument as document.

This makes XSLT generated html pages different in many ways then normal html-
pages, for example:
* All html-related methods/attributes on the document, such as .forms
  and .links, are missing.
* All element-names will be lowercased
* CSS is case-sensitive
* getElementsByTagName is case-sensitive

I've started working on fixing this. However it's not an easy task since we 
have to postpone creation of the document until we know if we should create an 
html or an xml one. This forces us to live without a result document in many 
situations when we are used to have it (when creating RTFs, when creating root 
comments and PIs)

I may or may not be able to finish this before 1.0
Blocks: 109918
Created attachment 75191 [details] [diff] [review]
patch for content. WIP, just for safekeeping
Created attachment 75192 [details] [diff] [review]
patch for transformiix. WIP, just for safekeeping
Created attachment 78874 [details] [diff] [review]
2nd patch for content. WIP
Attachment #75191 - Attachment is obsolete: true
Created attachment 78876 [details] [diff] [review]
2nd patch for transformiix. WIP

The two above patches builds and runs. However i get tons of assertions and
styleing doesn't seem to fully work. Also the DOM Inspector ends up inspecting
the source-document instead of the result-document. So more work is defenetly
needed
Attachment #75192 - Attachment is obsolete: true

Comment 5

16 years ago
I'm not really sure if I like the xslt in the topics. Never really did.
Not sure if we need to "namespace" the topics, though.
Is there any use in adding a "progress" topic?

Should we add for extension output methods for xul and svg?

And I'd really like to land this with bug 90157, which peterv works on.

Transforming to existing document should continue to work, now that we just
fixed it.

I didn't look too closely on the patch, I need a map to get thru all that
output stuff. I'll get my head out of the sand once Jonas and Peter are on 
common grounds what each of these interfaces needs.
Target Milestone: --- → mozilla1.1beta
*** Bug 142529 has been marked as a duplicate of this bug. ***
*** Bug 152046 has been marked as a duplicate of this bug. ***
note to self: bug 150916 will probably affect the patch
Target Milestone: mozilla1.1beta → mozilla1.2beta

Comment 9

16 years ago
one thing we should look at once this is done is quirks mode.
esp images within tables cause trouble, see bug 22274. This is was the
remaining issue in bug 86664, adding a img {display:block;} and removing the
borders brings us to the expected result, that is what quirks does.

Comment 10

16 years ago
the design for bug 90157 and bug 130161 need to worship each other.
Esp. one needs the creation of the document during the transform, the other
needs to work on an existing document.

Updated

16 years ago
Keywords: mozilla1.2

Updated

16 years ago
Depends on: 155578
*** Bug 159061 has been marked as a duplicate of this bug. ***

Comment 12

16 years ago
*** Bug 168852 has been marked as a duplicate of this bug. ***
*** Bug 169123 has been marked as a duplicate of this bug. ***
Alias: txxhtml
Status: NEW → ASSIGNED
*** Bug 170094 has been marked as a duplicate of this bug. ***

Comment 15

16 years ago
*** Bug 170915 has been marked as a duplicate of this bug. ***
fixed with the branch-landing
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 17

15 years ago
mass verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.