Video loading icon on YouTube is off centered when selecting RTL languages like Arabic

UNCONFIRMED
Unassigned

Status

Tech Evangelism
Desktop
P5
normal
Rank:
75
UNCONFIRMED
2 years ago
4 months ago

People

(Reporter: Abid, Unassigned)

Tracking

({rtl})

Trunk

Firefox Tracking Flags

(platform-rel -)

Details

(Whiteboard: [platform-rel-Youtube])

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8789829 [details]
loading sign not centered in youtube.

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.116 Safari/537.36 OPR/39.0.2256.71

Steps to reproduce:

My info:
Build id: 20160901004001
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0

Steps to reproduce: 
1) First of all go to firefox Aurora (Developer Edition) 50.0a2 (2016-09-01) in RTL locates (arabic).
2) Go to youtube.com 
3) Click on a video.




Actual results:

While the video was loading, loading sign was not at the center of the video playing section.


Expected results:

The loading sign should be at the center of the video playing section.

Updated

2 years ago
Component: Untriaged → Layout
Keywords: rtl
Product: Firefox → Core
Summary: Video loading icon on youtube.com is off centered. → Video loading icon on youtube.com is off centered in RTL Arabic locale

Comment 1

2 years ago
I don't think RTL locale is an issue here, you can reproduce it with FF48 en-US by just selecting Arabic language in YouTube.

Comment 2

2 years ago
It appears only with the HTML5 player on YT, it's fine with the Flash player.
Summary: Video loading icon on youtube.com is off centered in RTL Arabic locale → Video loading icon on YouTube is off centered when selecting RTL languages like Arabic
I have reproduced this bug with Firefox 48.0

Build   ID 20160726073904
User Agent Mozilla/5.0(Windows NT 6.1; Win64; x64; rv:48.0) Gecko/20100101 Firefox/48.0

https://drive.google.com/open?id=0B75_JfziYeofYW1aeVlGQldia28
platform-rel: --- → ?
Whiteboard: [platform-rel-Youtube]

Updated

2 years ago
platform-rel: ? → +

Updated

2 years ago
Rank: 75
Is this a Gecko bug? Maybe Mike has thoughts on that.
Flags: needinfo?(miket)

Comment 5

2 years ago
(In reply to Andrew Overholt [:overholt] from comment #4)
> Is this a Gecko bug? Maybe Mike has thoughts on that.

No, IE11 has the same issue when you select Arabic lang in the footer of YouTube.
It's a TE bug for me.
Created attachment 8815007 [details]
Screenshot in Chrome

Nah, not a Gecko bug. This also reproduces in Chrome, so just a CSS bug.
Flags: needinfo?(miket)

Updated

2 years ago
Component: Layout → Desktop
Product: Core → Tech Evangelism
Version: 50 Branch → Trunk
You need to log in before you can comment on or make changes to this bug.