Closed Bug 1301716 Opened 6 years ago Closed 6 years ago

Pref off new debugger in tests that require old debugger

Categories

(DevTools :: Debugger, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1300861

People

(Reporter: jlong, Assigned: jlong)

References

Details

Attachments

(3 files)

There are several older tests in other tools that assume the window has state that the older debugger created. We need to fix up these tests, but we want to turn on the new debugger now so we're going to just force those specific tests to keep using the old debugger.
Blocks: 1300861
Attached patch 1301716.patchSplinter Review
Fixes the following tests:

devtools/client/webconsole/test/browser_console_optimized_out_vars.js
devtools/client/webconsole/test/browser_console_variables_view_while_debugging.js
devtools/client/webconsole/test/browser_console_variables_view_while_debugging_and_inspecting.js 
devtools/client/webconsole/test/browser_eval_in_debugger_stackframe.js
devtools/client/webconsole/test/browser_eval_in_debugger_stackframe2.js
devtools/client/webconsole/test/browser_webconsole_autocomplete_in_debugger_stackframe.js
devtools/client/webconsole/test/browser_webconsole_bug_1050691_click_function_to_source.js
devtools/client/webconsole/test/browser_webconsole_bug_766001_JS_Console_in_Debugger.js
devtools/client/webconsole/test/browser_webconsole_closure_inspection.js 
devtools/client/webconsole/test/browser_webconsole_input_field_focus_on_panel_select.js
When we run a try push, we'll should include bug 1301719 which fixes a bunch of browser toolbox/addons tests.
Assignee: nobody → jlong
Let's merge this with bug 1300861, as it's difficult to track a lot of moving parts.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1300861
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.