cannot create .url file when dragging the icon in the url bar due to invalid chars for filenames in the site title

VERIFIED DUPLICATE of bug 78509

Status

VERIFIED DUPLICATE of bug 78509
17 years ago
11 years ago

People

(Reporter: tom+mozilla, Assigned: hewitt)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002020406

When a page has a title that contains characters not allowed in Windows
filenames (such as http://slashdot.org), there is a file creation error when
trying to create a shortcut (.url file) via dragging the icon in the URL bar
(far left) to the desktop or another folder.

Reproducible: Always
Steps to Reproduce:
1. Go to http://slashdot.org (for example).
2. Drag icon in the far left of the URL bar to the desktop.

Actual Results:  An error dialog with the title "Desktop" pops up with the text:

"C:\Documents and Settings\Username\Desktop\Slashdot:\ is not accessible.  The
filename, directory name, or volume label syntax is incorrect."

After clicking "OK", another dialog titled "Error Copying File or Folder" pops
up with the text:

"The filename, directory name, or volume label syntax is incorrect."

Expected Results:  The invalid characters should have been removed from the
filename before the file was attempted to be created so that the file creation
succeeded and the link was created to the page.

<html>
<head>
  <title>This title has a : (colon) in it!</title>
</head>
<body>
  The characters not allowed in Windows filenames are:
    \ / : * ? " < > |
</body>
</html>

Comment 1

17 years ago
dup of bug 78509. Please reopen if you can reproduce the problem with a current
nightly or the just released 0.9.9

*** This bug has been marked as a duplicate of 78509 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
v
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.