menu arrow panel is truncated under specific browser position or if the menu arrow panel has many toolbutton

VERIFIED WORKSFORME

Status

()

Firefox
Toolbars and Customization
VERIFIED WORKSFORME
2 years ago
2 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

({regression})

Trunk
x86
Windows 10
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8790023 [details]
screenshot

Steps To Reproduce:
1. Move browser window
2. Click menu button

Actual Results:
Menu arrow panel is truncated under specific browser position
See screen shot

Expected Results:
Opt1. Menu arrow panel should pop up toward the opposite side.
Opt2. Menu arrow panel should have vertical scroll bar.
(Reporter)

Comment 1

2 years ago
[Tracking Requested - why for this release]: Inpossible to interact menu item

Regression window:
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=bc160abe215baed95384cb10e17118b168caa05a&tochange=dd8193695d2d56667f22a32b77adc243a034cfd2

Regressed by:dd8193695d2d	Florian Quèze — Bug 1206233 - Avoid flickering of the panel when removing permission items, r=jaws
Blocks: 1206233
Severity: minor → normal
status-firefox50: --- → unaffected
tracking-firefox51: --- → ?
Keywords: polish → regression
(Reporter)

Comment 2

2 years ago
Created attachment 8790050 [details]
screenshot version2

The problem is worse if there is a lot of toolbuttons on the arrow panel of the menu.
It cannot be avoided except to remove toolbuttons.
(Reporter)

Updated

2 years ago
Flags: needinfo?(florian)
(Reporter)

Updated

2 years ago
Summary: menu arrow panel is truncated under specific browser position → menu arrow panel is truncated under specific browser position or if the menu arrow panel has many toolbutton
The patch referenced in comment 1 will be backed out as part of the (temporary) fix for bug 1299437. Would be great if you could retest this once bug 1299437 is resolved.
Flags: needinfo?(florian)
See Also: → bug 1299437
hello Alice - Can you please retest when you get a chance? Thanks.
Flags: needinfo?(alice0775)
(Reporter)

Comment 5

2 years ago
(In reply to Marcia Knous [:marcia - use ni] from comment #4)
> hello Alice - Can you please retest when you get a chance? Thanks.

Verified.
I can no longer reproduce the problem on latest Nightly51.0a1. 

https://hg.mozilla.org/mozilla-central/rev/29af101880db7ce7f5f87f58e1ff20988c1c5fc3
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0 ID:20160915030417
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox50: unaffected → ---
status-firefox51: affected → ---
tracking-firefox51: ? → ---
Flags: needinfo?(alice0775)
Resolution: --- → WORKSFORME
(Reporter)

Updated

2 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.