Closed Bug 1301898 Opened 4 years ago Closed 4 years ago

Call Stack tab in Console request display takes a lot of space

Categories

(DevTools :: Console, defect)

defect
Not set

Tracking

(firefox51 verified)

VERIFIED FIXED
Firefox 51
Tracking Status
firefox51 --- verified

People

(Reporter: ntim, Assigned: jsnajdr)

References

Details

Attachments

(2 files)

Attached image Screenshot
No description provided.
Caused by the extra whitespace added to stack traces in bug 1298225.
Assignee: nobody → jsnajdr
Blocks: 1298225
There is a CSS rule at [1] that sets "white-space: pre-wrap" to the .message-body. It's intended to show whitespace and break lines in console messages (e.g., console.log("\thello\nworld"), but as an unwanted side-effects, it breaks the netlogging stacktraces by making its internal whitespace markup visible.

[1] http://searchfox.org/mozilla-central/source/devtools/client/themes/webconsole.css#143
Comment on attachment 8790232 [details]
Bug 1301898 - Fix white-space style of console netlogging stack trace

https://reviewboard.mozilla.org/r/78142/#review76762

Thanks, tested locally and it works for me!
Attachment #8790232 - Flags: review?(bgrinstead) → review+
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/fx-team/rev/c273bf6370c3
Fix white-space style of console netlogging stack trace r=bgrins
Duplicate of this bug: 1302372
https://hg.mozilla.org/mozilla-central/rev/c273bf6370c3
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51
Works for me. Thank you for the fix!

Sebastian
Status: RESOLVED → VERIFIED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.