Status

()

Core
HTML: Form Submission
VERIFIED INVALID
17 years ago
17 years ago

People

(Reporter: Albert Croft, Assigned: Alexandru Savulov)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031109

Page is a form with embedded javascript code. Upon selecting answers to each
question, pressing the submit button at the bottom does not carry the user to
the results page.

Reproducible: Always
Steps to Reproduce:
1.Select answers for each question on page
2.Click submit button
3.

Actual Results:  Values were not submitted.

Expected Results:  Form results should have been displayed.

Tried from two machines, both running 0.9.9/2002031109/X11/Linux (latest-0.9.9),
same results.

Comment 1

17 years ago
Same with 2002031103/Win2K. In NN4.79 and MSIE 5.0 form works.
Form in page hasn't setted attributes METHOD and ACTION, so maybe this bug
should be moved to Tech Evang.
Keywords: 4xp
OS: Linux → All

Comment 2

17 years ago
Actually, the JS on this page is very very poor.
I finally succeeded to have it working by suppressing
the script related to right mouse clicking (which is
completly weird) and by declaring and initializing the
variable "value" in the "process()" function.

Note that all faults are visible in the JS console.

Since this is a bad coding, resolving as INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 3

17 years ago
Based on the coments it looks like and invalid bug, and since the site is down
I'm verifying it.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.