update harfbuzz to upstream release 1.3.1

RESOLVED DUPLICATE of bug 1313097

Status

()

Core
Layout: Text
RESOLVED DUPLICATE of bug 1313097
a year ago
a year ago

People

(Reporter: Krasnaya Ploshchad’, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160907153016

Steps to reproduce:

https://cgit.freedesktop.org/harfbuzz/commit/?id=d22ab6cf040467e7f17476ccdfe9cab4dce16639

Overview of changes leading to 1.3.1
Wednesday, September 7, 2016
====================================

- Blacklist bad GDEF of more fonts (Padauk).
- More CoreText backend crash fixes with OS X 10.9.5.
- Misc fixes.
(Reporter)

Updated

a year ago
Depends on: 1269343
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 1

a year ago
https://cgit.freedesktop.org/harfbuzz/commit/?id=f73a87d9a8c76a181794b74b527ea268048f78e3

Overview of changes leading to 1.3.2
Wednesday, September 27, 2016
====================================

- Fix build of hb-coretext on older OS X versions.

Note: This version also includes MATH support, but the related documentation is not included in this version, see their repo.
(Reporter)

Comment 2

a year ago
https://cgit.freedesktop.org/harfbuzz/commit/?id=966ac7ecd3d0128a3adacdd26aacef2bd8afa4d4

Overview of changes leading to 1.3.3
Wednesday, September 28, 2016
====================================

- Implement parsing of OpenType MATH table.
New API:
HB_OT_TAG_MATH+HB_OT_MATH_SCRIPT
hb_ot_math_constant_t
hb_ot_math_kern_t
hb_ot_math_glyph_variant_t
hb_ot_math_glyph_part_flags_t
hb_ot_math_glyph_part_t
hb_ot_math_has_data
hb_ot_math_get_constant
hb_ot_math_get_glyph_italics_correction
hb_ot_math_get_glyph_top_accent_attachment
hb_ot_math_get_glyph_kerning
hb_ot_math_is_glyph_extended_shape
hb_ot_math_get_glyph_variants
hb_ot_math_get_min_connector_overlap
hb_ot_math_get_glyph_assembly
Thanks, I think this is now fixed by bug 1313097.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1313097
No longer depends on: 1269343
You need to log in before you can comment on or make changes to this bug.