Closed Bug 1302011 Opened 3 years ago Closed 3 years ago

Content process freezed if findbar.modalHighlight=true and iframe nested

Categories

(Toolkit :: Find Toolbar, defect, P1)

51 Branch
defect
Points:
3

Tracking

()

VERIFIED FIXED
mozilla51
Iteration:
51.3 - Sep 19
Tracking Status
firefox51 --- disabled
firefox52 --- verified

People

(Reporter: euthanasia_waltz, Assigned: mikedeboer)

References

(Blocks 1 open bug, )

Details

Attachments

(1 file)

STR:
1. Open http://www.w3schools.com/tags/tryit.asp?filename=tryhtml_iframe
2. Hit Ctrl+F and type "w3"

ER:
"w3"s are highlighted

AR:
"w" is highlighted
And the content process is freezed.

If findbar.highlightAll=false, "w3" is highlighted but clicking the next button(or hit F3) - "w3" in the right pane(nested iframe) should be highlighted - causes the content process freezed.

Regression range:
13:36.22 INFO: Last good revision: c0c2f6077694008794c06900943654db0143c2b9
13:36.22 INFO: First bad revision: 4988e9ed22f34ffa92723a16b0be9f82f48fe3e9
13:36.22 INFO: Pushlog:
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=c0c2f6077694008794c06900943654db0143c2b9&tochange=4988e9ed22f34ffa92723a16b0be9f82f48fe3e9
Blocks: 1291278
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to atlanto from comment #0)
> STR:
> 1. Open http://www.w3schools.com/tags/tryit.asp?filename=tryhtml_iframe
> 2. Hit Ctrl+F and type "w3"
> 
> ER:
> "w3"s are highlighted
> 
> AR:
> "w" is highlighted
> And the content process is freezed.
> 
> If findbar.highlightAll=false, "w3" is highlighted but clicking the next
> button(or hit F3) - "w3" in the right pane(nested iframe) should be
> highlighted - causes the content process freezed.

I've had this too and I don't need to investigate even to know what's going on here: infinite level of iframes. All I have to do here to remedy this is fix the FinderIterator to only recurse a certain max amount of iframes deep.

It'll be hard to find another website that exhibits this behavior, by the way.
Duplicate of this bug: 1302049
http://forums.mozillazine.org/ seems to be affected.
Ugh! Seems I was wrong then :)
Assignee: nobody → mdeboer
Status: NEW → ASSIGNED
Priority: -- → P1
Iteration: --- → 51.3 - Sep 19
Points: --- → 3
Flags: qe-verify+
Flags: firefox-backlog+
I see a consistent hang when I use Find in the eBay watched item list on Windows 7, but not on Linux. The hang happens with E10s off and on.
Duplicate of this bug: 1302756
Also, find-in-page in any Etherpad will cause a hanging process.
Duplicate of this bug: 1302915
Comment on attachment 8791544 [details]
Bug 1302011 - if we keep referencing window, currWin will always remain the same, thus never reaching window.top to stop the while-loop.

https://reviewboard.mozilla.org/r/78944/#review77524
Attachment #8791544 - Flags: review?(gijskruitbosch+bugs) → review+
Pushed by mdeboer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6f7790dbfa0f
if we keep referencing window, currWin will always remain the same, thus never reaching window.top to stop the while-loop. r=Gijs
Thanks Gijs!
https://hg.mozilla.org/mozilla-central/rev/6f7790dbfa0f
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
QA Contact: brindusa.tot
Reproduced the initial hangs/crashes using the STR from the Description and from the duplicate bugs on Nightly 51.0a1 (build ID: 20160911030419) on Windows 10. 

Verified as fixed using the latest Nightly 52.0a1 (Build ID: 20160926030203) and following the instructions from the description and duplicate bugs on: Windows 10, Ubuntu 16.04 and Mac OS X 10.11.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.