You should be redirected to website with client certificate the first time after adding a permanent exception

RESOLVED INVALID

Status

()

Firefox for Android
General
RESOLVED INVALID
2 years ago
a year ago

People

(Reporter: Alex Caziuc, Unassigned)

Tracking

({regression})

48 Branch
ARM
Android
regression
Points:
---

Firefox Tracking Flags

(firefox48 wontfix, firefox49 wontfix, firefox50 affected, firefox51 affected, firefox52 affected)

Details

(Reporter)

Description

2 years ago
Tested using Galaxy Note 5(6.0.1) on 48 Release.

1. Clean profile
2. Open FF -> Go to https://adalet.gov.tr/ 
3. Tap 'I Understand the Risks' -> tap 'Add permanent exception'
4. Repeat step 3 -> you get redirected to the page

Actual result:
You are redirected to the page only after step 4

Expected result:
You should be redirected to the website the first time after you add it as a permanent exception(step3)
Is this a regression?
Flags: needinfo?(alex.caziuc)
(Reporter)

Comment 2

a year ago
It's an old regression. I reproduced it even in 32 Release.
Flags: needinfo?(alex.caziuc)

Updated

a year ago
Keywords: regression
OS: Unspecified → Android
Hardware: Unspecified → ARM
(Reporter)

Comment 3

a year ago
After further investigation I was able to reproduce this on Beta 49, Aurora 50,51 and Nightly 52 with the following devices: One A2001(Android 6.0.1), Xiaomi mi4i (Android 5.0.2), Sony Xperia Z5(Android 6.0.1) and Galaxy Note 5 (Android 6.0.1).

However I can't reproduce it on tablets as: Nexus 9(Android 6.0.1), Galaxy Tab S2(Android 6.0.1), Xiaomi MI PAD 2(Android 5.1)
status-firefox49: --- → affected
status-firefox50: --- → affected
status-firefox51: --- → affected
status-firefox52: --- → affected
Snorp, what do you think?  It makes sense that you shouldn't have to declare it as an exception twice.
status-firefox48: affected → wontfix
status-firefox49: affected → wontfix
Flags: needinfo?(snorp)
I think the reason you get two prompts is because on phones it seems to redirect to https://www.adalet.gov.tr/m, which is a different domain, hence the second prompt. On a tablet (and desktop), you are not redirected, so no second prompt.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(snorp)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.