Firefox crash on a 3 MJPEG stream page

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: nicolas.hermestroff, Unassigned)

Tracking

({crash, testcase-wanted})

48 Branch
x86_64
Windows 7
crash, testcase-wanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8790238 [details]
testcam_mjpg.html

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160725105554

Steps to reproduce:

I have 3 cameras that provide a mjpeg stream each. I created an html page (attached) that just open the stream as IMG. after some time, firefox crash.

I read that it could be a memory leak : about:memory display something like 130MB used and is stable.

I though it could be linked to a plugin : everything is disabled. About extensions, only ReloadEvery is enabled. I disabled it (as I did previously) to confirm it is still failing. AntiVirus as been removed on this machine (McAfee)


Actual results:

Crash reporter is displayed and firefox asks to quit or to restart


Expected results:

Nothing
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
(Reporter)

Comment 2

2 years ago
URL in the file attached has been truncated, normally the three are with user, password and domain name (eg : http://user:pass@camxx.domain.name/stream)
(Reporter)

Comment 3

2 years ago
I confirm I reproduce the crash with ReloadEvery disabled
https://crash-stats.mozilla.com/report/index/0d5743f1-351e-4f14-b963-8915d2160912

Comment 4

2 years ago
We need a full working testcase to reproduce the crash. Is it possible to update your testcase with true cam link?
Severity: normal → critical
Flags: needinfo?(nicolas.hermestroff)
Keywords: crash, testcase-wanted
(Reporter)

Comment 5

2 years ago
I am unsure how to do that as those are on a private network. I'll work on it.

Yet I am testing something else : Firefox 51. Until now (23 hours), it didn't failed so I'll update the case asap to confirm if it is solved in newer release.

Comment 6

2 years ago
Yes, it could be already fixed in the next versions like FF50 or 51, especially when it's a crash. Report if the issue is still here.

If that's the case, maybe we can try a solution to build a testcase accessible by Mozilla devs.
Component: Untriaged → ImageLib
Product: Firefox → Core
(Reporter)

Comment 7

2 years ago
OK, I confirm in two days, Firefox 51 with EveryReload doesn't crash anymore. This is an acceptable workaround so I will close the request.

Thank you for your time and patience.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(nicolas.hermestroff)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.