single-click and drag in address field selects from start of line, not from mouse down position.

VERIFIED DUPLICATE of bug 62495

Status

()

VERIFIED DUPLICATE of bug 62495
17 years ago
17 years ago

People

(Reporter: david+bugzilla, Assigned: mjudge)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.9) Gecko/20020310
BuildID:    2001301005

Single clicking in the browser window selects everything. Annoying, but
debatably consistent with other browsers. However single clicking and then
dragging the mouse does NOT behave as expected. It begins the selection at the
start of the address, and dragging sets the end-point. What *should* happen is
the selection should start at the point where I click the mouse and then extend
to where I let up on the mouse button. This clearly violates the user interface
guidelines on at least one of your target platforms and should be fixed. 

Reproducible: Always
Steps to Reproduce:
1. Click in the address bar, hold down the button.
2. Move the mouse.
3. Let up on the button.
:-)

Actual Results:  It begins the selection at the start of the address, and
dragging sets the end-point.

Expected Results:  What *should* happen is the selection should start at the
point where I click the mouse and then extend to where I let up on the mouse button.

Comment 1

17 years ago
-->selection
Assignee: kin → mjudge
Component: Editor: Core → Selection
QA Contact: sujay → tpreston

Comment 2

17 years ago

*** This bug has been marked as a duplicate of 62495 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.