Closed Bug 1302076 Opened 6 years ago Closed 6 years ago

Unity Web Player Plugin - going into fullscreen by clicking it from the game's context menu, turns out that the game’s left and right sides are being cut/cropped

Categories

(Core :: Graphics, defect)

defect
Not set
normal

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox48 --- affected
firefox49 --- affected
firefox50 --- affected
firefox51 --- affected

People

(Reporter: ciprian_georgiu, Unassigned)

Details

(Whiteboard: [gfx-noted])

[Notes]:
- Screenshot attached http://imgur.com/a/gvqwY

[Affected versions]:
- latest Nightly 51.0a1 (2016-09-07)
- latest Aurora 50.0a2 (2016-09-07)
- Firefox Beta 49.0b10
- Firefox Release 48.0.2

[Affected platforms]:
- Win 10 Pro, x64
- MAC OS Sierra 10.12 Beta

[Steps to reproduce]:
Prerequisites: if you don't have the Unity Web Player Plug-in, install it from here: https://unity3d.com/webplayer 
1. Launch Firefox
2. Access the next game that runs on Unity Web Player Plug-in http://chromianwars.com/demo/
3. Click Allow and Remember
4. Play the game
5. Right click on the video, then select Go Fullscreen from context menu

[Expected result]:
- The game is properly rendered on Fullscreen mode

[Actual result]:
- The game is not properly rendered, the left and right sides of the game are being cut/cropped.

[Regression range]:
- I will follow up with a regression range ASAP

[Additional notes]:
- Not applicable on Ubuntu
- On Internet explorer is not reproducible
- Use only x32 Firefox builds
Safari had similar problem. I think this is application problem?
Whiteboard: [gfx-noted]
Resolving as WONTFIX because we no longer support the Unity NPAPI plugin, or any other NPAPI plugins except Flash, in Firefox 52 (bug 1269807).
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.