Closed Bug 1302110 Opened 3 years ago Closed 3 years ago

Intermittent toolkit/content/tests/chrome/test_findbar.xul | Currently highlighted match should be at 3 for 'te' - got "4", expected "3"

Categories

(Toolkit :: Find Toolbar, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla52
Tracking Status
firefox50 --- unaffected
firefox51 --- fixed
firefox52 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: mikedeboer)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Flags: needinfo?(mdeboer)
Summary: Intermittent toolkit/content/tests/chrome/test_findbar.xul | Currently highlighted match should be at 1 for 'tes' - got "2", expected "1" → Intermittent toolkit/content/tests/chrome/test_findbar.xul | Currently highlighted match should be at 3 for 'te' - got "4", expected "3"
If you don't mind, I'm going to disable this part of the test on debug builds, using AppConstants.jsm
Flags: needinfo?(mdeboer)
Assignee: nobody → mdeboer
Status: NEW → ASSIGNED
This does what it says on the tin, but why is the test failing on debug? It feels like the test is just buggy...
Flags: needinfo?(mdeboer)
Comment on attachment 8807472 [details]
Bug 1302110 - disable the find counter specific tests on DEBUG builds only to stop frequent intermittents.

https://reviewboard.mozilla.org/r/90610/#review90326

rs=me for this doing what it says on the tin and stopping the frequent intermittents, but it's still surprising there's an opt/debug difference here, that isn't just "it's slow on debug so it times out".
Attachment #8807472 - Flags: review?(gijskruitbosch+bugs) → review+
I agree that it's odd. I'll file another bug where I'll be investigating this. Since I'm having trouble reproducing this locally, it might take a while to get to the root of it, but still.
Pushed by mdeboer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/12a0bf16d44d
disable the find counter specific tests on DEBUG builds only to stop frequent intermittents. r=Gijs
https://hg.mozilla.org/mozilla-central/rev/12a0bf16d44d
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Whiteboard: [checkin-needed-aurora]
Blocks: 1316862
Flags: needinfo?(mdeboer)
You need to log in before you can comment on or make changes to this bug.