Status

Tree Management
Treeherder: Log Viewer
--
critical
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: bz, Assigned: wlach)

Tracking

Details

Attachments

(2 attachments)

The "open raw log" link on https://treeherder.mozilla.org/logviewer.html#?repo=mozilla-inbound&job_id=34864667#L11783 doesn't work: it just opens up https://treeherder.mozilla.org/logviewer.html which then says there is no such job (because it wasn't handed a job id).

The DOM looks like this:

  <a title="Open the raw log in a new window" target="_blank" href="">
    stuff here
  </a>

Note the not-so-great href value.
Summary: Raw log links brooken → Raw log links broken
The link's supposed to get parsed in here: https://github.com/mozilla/treeherder/blob/f0105d47f5cd72cbb8742025567c2ca17463f73e/ui/logviewer.html#L52

No clue why it isn't.
Fallout from bug 1258861, I'll fix. We no longer use the text log artifact here.
Assignee: nobody → wlachance
Blocks: 1258861
Created attachment 8790441 [details] [review]
[treeherder] wlach:1302224 > mozilla:master
Comment on attachment 8790441 [details] [review]
[treeherder] wlach:1302224 > mozilla:master

Sorry, we should have caught this earlier. The fix is simple and has already been deployed to production as a hotfix.
Attachment #8790441 - Flags: review?(wkocher)
Comment on attachment 8790441 [details] [review]
[treeherder] wlach:1302224 > mozilla:master

Looks like what I would do.
Attachment #8790441 - Flags: review?(wkocher) → review+
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Is this deployed?  Because I'm still seeing the same broken behavior...
Flags: needinfo?(wlachance)
I'm almost positive this was deployed to production, but I still see the broken behavior with the link from comment 0 (and more recent failures, if jobs needed to be ingested after this was deployed), too...

But if I run ./web-server.js locally with the tip of the master branch, it works for me.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Hmm, yes, still seems to reproducible. Weird, my fix work locally. Investigating...
Flags: needinfo?(wlachance)
Created attachment 8791204 [details] [review]
[treeherder] wlach:1302224-2 > mozilla:master
Comment on attachment 8791204 [details] [review]
[treeherder] wlach:1302224-2 > mozilla:master

There was a race between downloading the job information and rendering the template, because I added an "optimization" to not re-render the link on a digest cycle. In practice, the time taken to re-render the template is trivial.

Lesson learned: only use the "::" syntax where you really need it, and be careful about follow on effects.

I've applied the change as a hotfix to production, but I'll file this for review all the same. :)
Attachment #8791204 - Flags: review?(wkocher)
Comment on attachment 8791204 [details] [review]
[treeherder] wlach:1302224-2 > mozilla:master

rs=me
Attachment #8791204 - Flags: review?(wkocher) → review+

Comment 14

2 years ago
Commit pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/2b65fa5ee474f7e90e86f972b463129032c96510
Bug 1302224 - Make sure raw log link in logviewer works (#1850)

We need to update the template value on angular digest cycles, because
we can't count on the "raw log url" being available when we first render the
template (the job may still be loading).
Hopefully this is really fixed now.
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.