Closed Bug 1302310 Opened 3 years ago Closed 3 years ago

Consider make video control's width match the size of video element

Categories

(Toolkit :: Video/Audio Controls, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla53
Tracking Status
firefox53 --- verified

People

(Reporter: ralin, Assigned: ralin)

References

Details

Attachments

(2 files)

per comment 46 of bug 1271765, file another bug for the discussion.

Right now video control matches the size of video region inside video element, we should consider make video control match the size of video element.
Attached image preview.jpg
Hi Stephen,
Based on our offline discussion, could you comment your opinions about the video control set width? Currently the set width is following the video size. We would like to propose to change it to be fixed with the window length. (please see attachment)
Thanks!
Flags: needinfo?(shorlander)
Making the width of the video controls match the video container vs. the video region looks a lot nicer to me. It may also be slightly more technically correct since the controls apply to the entire container.
Flags: needinfo?(shorlander)
Assignee: nobody → ralin
Status: NEW → ASSIGNED
Comment on attachment 8813025 [details]
Bug 1302310 - Make the width of video control match video container.

https://reviewboard.mozilla.org/r/94550/#review94994
Attachment #8813025 - Flags: review?(jaws) → review+
Keywords: checkin-needed
Pushed by ihsiao@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/23673ee58fea
Make the width of video control match video container. r=jaws
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/23673ee58fea
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Flags: qe-verify+
I managed to reproduce this issue on Firefox 52.0, under Windows 10x64.
The issue is no longer reproducible on Firefox 53.0b2, under Ubuntu 16.04x64, Mac OS X 10.12.3, or under Windows 10x64.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.