add a test to confirm that video control show "noaudio" icon when video has no audio

RESOLVED FIXED in Firefox 53

Status

()

Toolkit
Video/Audio Controls
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: ralin, Assigned: ralin)

Tracking

(Blocks: 1 bug)

unspecified
mozilla53
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox53 fixed)

Details

MozReview Requests

()

Submitter Diff Changes Open Issues Last Updated
Loading...
Error loading review requests:

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
We should add a test to chek video UI when video has no audio. The test need to confirm that "noaudio" show up, in other hand, mute/unmute button and volume control are hidden.
(Assignee)

Updated

2 years ago
Blocks: 1303958
(Assignee)

Updated

2 years ago
Assignee: nobody → ralin
Status: NEW → ASSIGNED
Comment hidden (mozreview-request)
(Assignee)

Comment 2

2 years ago
temporarily hold from review for bug 1271765
Comment on attachment 8801023 [details]
Bug 1302320 - add noaudio icon test for video control.

https://reviewboard.mozilla.org/r/85832/#review84980

::: toolkit/content/tests/widgets/mochitest.ini:7
(Diff revision 1)
>  skip-if = buildapp == 'mulet' || buildapp == 'b2g'
>  support-files =
>    audio.wav
>    audio.ogg
>    seek_with_sound.ogg
> +  video.ogg

What's the size of the video file? Did you |git add| it? Can we reuse /mozilla-central/source/browser/base/content/test/general/video.ogg ?
(Assignee)

Comment 4

2 years ago
The file is existed on repo alreay, I didn't do |git add| here. It looks like this file has never been used since 2008(first added).
(Assignee)

Updated

2 years ago
Depends on: 1271765
Comment hidden (mozreview-request)

Comment 6

2 years ago
mozreview-review
Comment on attachment 8801023 [details]
Bug 1302320 - add noaudio icon test for video control.

https://reviewboard.mozilla.org/r/85832/#review94996
Attachment #8801023 - Flags: review?(jaws) → review+
(Assignee)

Updated

2 years ago
Keywords: checkin-needed

Comment 7

2 years ago
Pushed by ihsiao@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/84fee6da47a6
add noaudio icon test for video control. r=jaws
Keywords: checkin-needed

Comment 8

2 years ago
sorry had to backout for test_videocontrols_video_noaudio.html assertion failure, https://treeherder.mozilla.org/logviewer.html#?job_id=7078899&repo=autoland#L2408
Flags: needinfo?(ralin)
(Assignee)

Comment 9

2 years ago
Thank you Iris, I'll go fix it or maybe consider excluding this test from Android.
Flags: needinfo?(ralin)

Comment 10

2 years ago
Backout by ihsiao@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8ea8de32a32a
Backed out changeset 84fee6da47a6 for test_videocontrols_video_noaudio.html assertion failure
Comment hidden (mozreview-request)
(Assignee)

Comment 12

2 years ago
Skipped this test on Android platform due to mobile video control doesn't care about `noaudio` state.
Keywords: checkin-needed

Comment 13

2 years ago
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4e27de747d61
add noaudio icon test for video control. r=jaws
Keywords: checkin-needed

Comment 14

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/4e27de747d61
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox53: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
You need to log in before you can comment on or make changes to this bug.