SVG events on element with float value positions not always working

RESOLVED DUPLICATE of bug 1167959

Status

()

P3
normal
RESOLVED DUPLICATE of bug 1167959
2 years ago
5 days ago

People

(Reporter: kubrick, Unassigned)

Tracking

53 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

2 years ago
Created attachment 8790640 [details]
float.html

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20160912030421

Steps to reproduce:

See the attached float.html


Actual results:

Every rectangle should respond to the mouse over event, only one does. Works on Chrome.
(Reporter)

Comment 1

2 years ago
Created attachment 8790642 [details]
integers.html

working with integer values only doesn't cause this problem (but I can't use it in my project because I'm depending on other libraries that expect floating point values to work).
Component: Untriaged → SVG
Product: Firefox → Core
(Reporter)

Comment 2

2 years ago
I think it's a precision issue, if at any time in the scale conversion any of the position attributes becomes too small (~<0.0001) it gets truncated and doesn't get "scaled back up" from the DOM's point of view although it gets displayed properly.
(Reporter)

Updated

2 years ago
Version: 51 Branch → 52 Branch
(Reporter)

Comment 3

2 years ago
Hello,

Any progress on that? This is causing major usability issues with libraries like OpenSeaDragon...

F.
Comment hidden (obsolete)
(Reporter)

Updated

2 years ago
OS: Unspecified → All
Hardware: Unspecified → All
Version: 52 Branch → 53 Branch
Comment hidden (advocacy)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Comment hidden (obsolete)
Priority: -- → P3

Comment 7

5 days ago
Created attachment 9009726 [details]
Reduced test case (with 1/60 grid points)

I'm getting the same results here as in bug 1167959 - the role of the viewBox transform in that bug is being played by the scale transform on the <g> in this bug.  (I'm also seeing an identity transform on the anonymous child, but I guess that always happens since bug 1458968.)

The testcase here includes the relevant 1/60 grid points discussed in bug 1167959 - the yellow one was the one I hit in a test run.

Updated

5 days ago
Status: NEW → RESOLVED
Last Resolved: 5 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1167959
You need to log in before you can comment on or make changes to this bug.