Abort | X_ShmAttach: BadAccess (attempt to access private resource denied); 3 request... | mozalloc_abort | NS_DebugBreak | X11Error

RESOLVED DUPLICATE of bug 1271100

Status

()

Core
Graphics
P2
normal
RESOLVED DUPLICATE of bug 1271100
a year ago
a year ago

People

(Reporter: ato, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: tpi:+)

(Reporter)

Description

a year ago
Firefox occasionally crashes when run over over SSH with X forwarding in officially branded builds.  This does not seem to happen on Nightly.

An example crash report is https://crash-stats.mozilla.com/report/index/fca7963e-4a5a-4b50-8d5e-7a4b62160913.

More examples can be found under comments: https://crash-stats.mozilla.com/signature/?product=Firefox&signature=Abort%20%7C%20X_ShmAttach%3A%20BadAccess%20%28attempt%20to%20access%20private%20resource%20denied%29%3B%203%20request...%20%7C%20mozalloc_abort%20%7C%20NS_DebugBreak%20%7C%20X11Error&_columns=date&_columns=product&_columns=version&_columns=build_id&_columns=platform&_columns=reason&_columns=address&_sort=-date&page=1#comments

To reproduce, run an officially branded Firefox build over X forwarding through SSH.  It’s enough to trigger the profile manager, but it will also happen if you start a profile.

   % ssh -YC HOST /path/to/branded/firefox -P

The error I get is:

% ssh -YC eir /home/ato/firefox/firefox -P
[14807] ###!!! ABORT: X_ShmAttach: BadAccess (attempt to access private resource denied); 3 requests ago: file /builds/slave/m-rel-l64-00000000000000000000/build/src/toolkit/xre/nsX11ErrorHandler.cpp, line 157
[14807] ###!!! ABORT: X_ShmAttach: BadAccess (attempt to access private resource denied); 3 requests ago: file /builds/slave/m-rel-l64-00000000000000000000/build/src/toolkit/xre/nsX11ErrorHandler.cpp, line 157
ExceptionHandler::GenerateDump cloned child 14853
ExceptionHandler::SendContinueSignalToChild sent continue signal to child
ExceptionHandler::WaitForContinueSignal waiting for continue signal...


If I run it with MOZ_X_SYNC, I get this:

% MOZ_X_SYNC=1 ssh -YC eir /home/ato/firefox/firefox -P
[14862] ###!!! ABORT: X_ShmCreatePixmap: BadShmSeg (invalid shared segment parameter); 6 requests ago: file /builds/slave/m-rel-l64-00000000000000000000/build/src/toolkit/xre/nsX11ErrorHandler.cpp, line 157
[14862] ###!!! ABORT: X_ShmCreatePixmap: BadShmSeg (invalid shared segment parameter); 6 requests ago: file /builds/slave/m-rel-l64-00000000000000000000/build/src/toolkit/xre/nsX11ErrorHandler.cpp, line 157
ExceptionHandler::GenerateDump cloned child 14908
ExceptionHandler::SendContinueSignalToChild sent continue signal to child
ExceptionHandler::WaitForContinueSignal waiting for continue signal...

Updated

a year ago
Priority: -- → P3
Whiteboard: tpi:+
Thanks for the report.  This may be fixed in Firefox 50.
Status: NEW → RESOLVED
Last Resolved: a year ago
Component: Widget: Gtk → Graphics
Keywords: regression
Priority: P3 → P2
Resolution: --- → DUPLICATE
Duplicate of bug: 1271100
You need to log in before you can comment on or make changes to this bug.