Make ZipCollection thread-safe

RESOLVED FIXED in Firefox 50

Status

()

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: esawin, Assigned: esawin)

Tracking

51 Branch
Firefox 51
All
Android
Points:
---

Firefox Tracking Flags

(firefox50 fixed, firefox51 fixed)

Details

Attachments

(1 attachment)

Moving patch 3 out of bug 1302189.
Pushed by esawin@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/5bfde65d691a
[1.2] Add mutex locking to ZipCollection zip vector access. r=glandium
https://hg.mozilla.org/mozilla-central/rev/5bfde65d691a
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51
We should probably uplift this (and maybe other linker fixes?)
Flags: needinfo?(esawin)
Comment on attachment 8790903 [details] [diff] [review]
0001-Bug-1302516-1.2-Add-mutex-locking-to-ZipCollection-z.patch

Approval Request Comment
[Feature/regressing bug #]: None
[User impact if declined]: Intermittent crashes on startup
[Describe test coverage new/current, TreeHerder]: Nightly only
[Risks and why]: Minimal, it just adds a mutex around container access
[String/UUID change made/needed]: None
Flags: needinfo?(esawin)
Attachment #8790903 - Flags: approval-mozilla-beta?
Attachment #8790903 - Flags: approval-mozilla-aurora?
Comment on attachment 8790903 [details] [diff] [review]
0001-Bug-1302516-1.2-Add-mutex-locking-to-ZipCollection-z.patch

Crash fix, Beta50+ 

(already on Aurora51)
Attachment #8790903 - Flags: approval-mozilla-beta?
Attachment #8790903 - Flags: approval-mozilla-beta+
Attachment #8790903 - Flags: approval-mozilla-aurora?
Duplicate of this bug: 1300274
Duplicate of this bug: 1300286
Duplicate of this bug: 1300327
Duplicate of this bug: 1300347
Duplicate of this bug: 1300945
Duplicate of this bug: 1301261
Duplicate of this bug: 1301268
Duplicate of this bug: 1301833
Duplicate of this bug: 1302618
Duplicate of this bug: 1302633
Duplicate of this bug: 1302852
Duplicate of this bug: 1302895
Duplicate of this bug: 1302897
Duplicate of this bug: 1300957
You need to log in before you can comment on or make changes to this bug.