Closed Bug 1302621 Opened 3 years ago Closed 3 years ago

Intermittent /html/browsers/browsing-the-web/history-traversal/browsing_context_name.html | Retaining window.name on history traversal - assert_equals: Initial load expected "test" but got ""

Categories

(Core :: DOM: Navigation, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla54
Tracking Status
firefox50 --- unaffected
firefox51 --- unaffected
firefox52 --- fixed
firefox-esr52 --- fixed
firefox53 --- fixed
firefox54 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: jgraham)

References

Details

(Keywords: intermittent-failure)

Attachments

(2 files)

James and/or Ms2ger, the timing of this appears to coincide with the upstream update from bug 1302423. It appears there was a change to that file included in the update, though it seems fairly innocuous?
https://github.com/w3c/web-platform-tests/commit/81207ecf9020aaea95cda2170a17421fd9d3f660

Anyway, this is a pretty regular failure on Windows mostly (but sometimes other platforms as well), so can you please take a look?
Component: web-platform-tests → Document Navigation
Flags: needinfo?(james)
Flags: needinfo?(Ms2ger)
Product: Testing → Core
See Also: → 1308969
Version: Version 3 → Trunk
It looks like the problem is here:

 onload = setTimeout(next, 0);

Possibly we end up running the first step as a result of the load event dispatched at the iframe, and then run the second step from the timeout, at which point the name is not yet set. I'm not sure how my change would have affected that, though...
Flags: needinfo?(Ms2ger) → needinfo?(geoffers+mozilla)
I have no idea about these tests; I may have originally committed them to wpt but they were written by James.
Flags: needinfo?(geoffers+mozilla)
Flags: needinfo?(james)
Comment on attachment 8828801 [details]
Bug 1302621 - Fix buggy history traversal test,

https://reviewboard.mozilla.org/r/106096/#review107860
Attachment #8828801 - Flags: review?(Ms2ger) → review+
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/autoland/rev/6f97023c9af9
Fix buggy history traversal test, r=Ms2ger
Attached patch manifest fixupSplinter Review
Attachment #8829888 - Flags: checkin?(cbook)
https://hg.mozilla.org/mozilla-central/rev/6f97023c9af9
https://hg.mozilla.org/mozilla-central/rev/6462429dd8eb
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
Assignee: nobody → james
Attachment #8829888 - Flags: checkin?(cbook)
James, would it be possible to whip up a Beta52 backport patch for this failure? It's pretty frequent on that branch and destined to be our next ESR. I took a quick stab at it but got caught in the weeds pretty quickly.
Flags: needinfo?(james)
You need to log in before you can comment on or make changes to this bug.