Closed Bug 1302639 (SM246-RELNOTE) Opened 3 years ago Closed 3 years ago

Create/Update 2.46 Release Notes

Categories

(SeaMonkey :: Website, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ewong, Unassigned)

References

()

Details

Attachments

(2 files)

+++ This bug was initially created as a clone of Bug #1294432 +++

SeaMonkey 2.46 release builds will be built soon.

These relnotes can be (begun to be) prepared ahead of the release date, but need to be out by our first beta release.
Blocks: SM2.46
(Quoting rsx11m from bug 1294432 comment #1, {with updates})
> Obvious new feature: "SeaMonkey {2.46} comes with the Lightning {5.1} calendar
> extension installed. On the first run of the Mail & Newsgroup window, you
> are offered to disable that feature if not desired."
> 
> Removed feature: "The option 'Ask me every time' in the Cookies preferences
> had to be removed as the backend core support was removed (Bug 606655)."
> 
> Known issue: "Setting the default search engine in the Internet Search
> preferences has no effect (Bug 1265881). You can still change it from the
> side bar [F9]."
> 
> Do we require SSE2-capable hardware for {2.46} already?

(Quoting Frank-Rainer Grahl from bug 1294432 comment #2)
> Another new feature: Mozilla developer tools are integrated in Seamonkey. 
> Disclaimer: Not all of the tools work yet because they were designed for
> Firefox only. We are trying to resolve this in a future update.
> 
> Fixed problems (the :
> 
> - Tracking Protection and Safe Browsing are working again (regression from 2.39/2.35).
> - The Data Manager should be able to edit and view all permissions and passwords again
>   (regression from 2.39).
> - The save bookmark dialog now shows the folder tree again (regression from 2.40). 
> 
> Known problems:
> 
> - Setting the default search engine no longer works. This is covered in bug 1265881.
> - Trying to play video files may crash the browser. See bug 1279851 for a workaround.
> If not reviewed by then:
> - The userchrome example files are not copied into a new profile. They can
>   be found in the Seamonkey installation directory in defaults/profile/chrome.
> If not reviewed by then:
> - The userchrome example files are not copied into a new profile. They can
>   be found in the Seamonkey installation directory in defaults/profile/chrome.

This one is gone. If 2.45 comes first only VS2015 support which requires SSE2 would be really new.
- Setting the default search engine no longer works. This is covered in bug 1265881.
> - Trying to play video files may crash the browser. See bug 1279851 for a workaround.

bug 1279851 has been uplifted to c-b and fixes the crash. I doubt it fixes the the underlying real problem but is working fine. We should include it in a special m-r release branch for SeaMonkey.
Sorry I meant bug 1279348.
See Also: → SM245-RELNOTE
Because the extensions were removed from 2.46 Lightning, cZ and DOMi locations should be put into the relnotes:

https://addons.mozilla.org/en-US/thunderbird/addon/lightning/versions/?page=1#version-5.1b1
https://addons.mozilla.org/en-US/seamonkey/addon/chatzilla/

If possible a current DOMi should be uploaded to AMO. I saw one report on mozillaZine where the old one broke 2.46:

http://forums.mozillazine.org/viewtopic.php?f=40&t=3025560

If this isn't possible we could put a link to Adrians version in the relnoted and suggest getting the latest one out of a Nightly zip package.

https://l10n.mozilla-community.org/~akalla/unofficial/seamonkey/nightly/latest-comm-release-windows64/inspector-2.0.17pre.xpi
Just the cloned release notes and some fixes to get the ball rolling. 

Downloading a release from 
http://www.seamonkey-project.org/releases/

now results in a certificate error. Is all which is needed to set mirrored to false so that it will download from archive.mozilla.org?
Depends on: 1325744
This patch adds a "What's new" section with one more-or-less important bullet point (IMHO) (YouTube fullscreen now working fine).
Comment on attachment 8821763 [details] [diff] [review]
Update release notes ("What's new")

Review of attachment 8821763 [details] [diff] [review]:
-----------------------------------------------------------------

The parser was spewing some emails and apparently there's a CR between relativet and o.name.

::: src/releases/seamonkey2.46/index.en.html
@@ +46,5 @@
> +<div class="section">
> +<p>
> +[% rnote.basename %] contains (among other changes) the following major changes relative to
> +<a href="../seamonkey[% rnote.relativeto.version %]/#new">[% rnote.relativet
> +o.name %]</a>:

rnote.relativeto.name
I would probably put the inclusion of the Firefox devtools also into it. Currently in release notes only.
(In reply to Edmund Wong (:ewong) from comment #9)
> Comment on attachment 8821763 [details] [diff] [review]
> Update release notes ("What's new")
> 
> Review of attachment 8821763 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> The parser was spewing some emails and apparently there's a CR between
> relativet and o.name.

Hrm, should have tested it on staging...fixed. https://hg.mozilla.org/SeaMonkey/seamonkey-project-org/rev/d01c9e58dbe23596442edb8aee7841966d95c4c0
I think this is fixed for 2.46
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Product: Websites → SeaMonkey
You need to log in before you can comment on or make changes to this bug.